summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2014-12-25 01:30:28 -0500
committerTimothy Crosley <timothy.crosley@gmail.com>2014-12-25 01:30:28 -0500
commitc6b7447c5d38431406e0f0bc79df1852618d2125 (patch)
tree4e6f800e610313b43c3ba92c63a070139a2e066e
parent593dcce07fdb3e8d0053a863a7aba7f2ce8a6c9c (diff)
parent958e601aac1522f94ab60f1917ed2758797b2dee (diff)
downloadpies-c6b7447c5d38431406e0f0bc79df1852618d2125.tar.gz
Merge branch 'release/2.6.2'2.6.2
-rw-r--r--.travis.yml11
-rw-r--r--README.md1
-rw-r--r--pies/StringIO.py2
-rw-r--r--pies/__init__.py2
-rw-r--r--pies2overrides/configparser.py3
-rw-r--r--pies2overrides/setup.py4
-rw-r--r--setup.py6
-rw-r--r--tox.ini11
8 files changed, 29 insertions, 11 deletions
diff --git a/.travis.yml b/.travis.yml
index 1e66aee..1c61464 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,7 +1,16 @@
language: python
python:
+ - "pypy"
- "2.6"
- "2.7"
- "3.2"
- "3.3"
-script: python setup.py test \ No newline at end of file
+install:
+ - if [[ $TRAVIS_PYTHON_VERSION == '2.6' ||
+ $TRAVIS_PYTHON_VERSION == '2.7' ||
+ $TRAVIS_PYTHON_VERSION == 'pypy' ]]; then
+ pip install ./pies2overrides;
+ fi
+script:
+ - pip install pytest
+ - py.test
diff --git a/README.md b/README.md
index 5be0bbd..a1bd99a 100644
--- a/README.md
+++ b/README.md
@@ -2,6 +2,7 @@
====================
[![PyPI version](https://badge.fury.io/py/pies.png)](http://badge.fury.io/py/pies)
[![PyPi downloads](https://pypip.in/d/pies/badge.png)](https://crate.io/packages/pies/)
+[![Build Status](https://travis-ci.org/timothycrosley/pies.png?branch=develop)](https://travis-ci.org/timothycrosley/pies)
[![License](https://pypip.in/license/pies/badge.png)](https://pypi.python.org/pypi/pies/)
[![Bitdeli Badge](https://d2weczhvl823v0.cloudfront.net/timothycrosley/pies/trend.png)](https://bitdeli.com/free "Bitdeli Badge")
diff --git a/pies/StringIO.py b/pies/StringIO.py
index fd5ce5e..d954a41 100644
--- a/pies/StringIO.py
+++ b/pies/StringIO.py
@@ -3,7 +3,7 @@ from __future__ import absolute_import
from .version_info import PY3
if PY3:
- from StringIO import *
+ from io import StringIO
else:
try:
from cStringIO import *
diff --git a/pies/__init__.py b/pies/__init__.py
index 2489aeb..b1aa082 100644
--- a/pies/__init__.py
+++ b/pies/__init__.py
@@ -28,4 +28,4 @@ CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFT
OTHER DEALINGS IN THE SOFTWARE.
"""
-__version__ = "2.6.1"
+__version__ = "2.6.2"
diff --git a/pies2overrides/configparser.py b/pies2overrides/configparser.py
deleted file mode 100644
index 4ae03e6..0000000
--- a/pies2overrides/configparser.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from __future__ import absolute_import
-
-from ConfigParser import *
diff --git a/pies2overrides/setup.py b/pies2overrides/setup.py
index 7644e22..ad5649d 100644
--- a/pies2overrides/setup.py
+++ b/pies2overrides/setup.py
@@ -14,12 +14,12 @@ if sys.version_info[0] == 2 and sys.version_info[1] < 7:
install_requires += ['ordereddict', 'argparse']
setup(name='pies2overrides',
- version='2.6.1',
+ version='2.6.2',
description='Defines override classes that should be included with pies only if running on Python2.',
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-2.6.1.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-2.6.2.tar.gz?raw=true',
license="MIT",
install_requires=install_requires,
requires=install_requires,
diff --git a/setup.py b/setup.py
index 0868339..fd13d9d 100644
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,7 @@ install_requires = []
if sys.version_info[0] < 3:
install_requires += ['pies2overrides']
elif sys.version_info[1] < 2:
- install_requires += ['argparse']
+ install_requires += ['argparse', 'configparser']
if sys.version_info[0] < 3 or sys.version_info[1] < 4:
install_requires += ['enum34']
@@ -24,13 +24,13 @@ except (IOError, ImportError, OSError, RuntimeError):
readme = ''
setup(name='pies',
- version='2.6.1',
+ version='2.6.2',
description='The simplest way to write one program that runs on both Python 2 and Python 3.',
long_description=readme,
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-2.6.1.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-2.6.2.tar.gz?raw=true',
license="MIT",
install_requires=install_requires,
requires=install_requires,
diff --git a/tox.ini b/tox.ini
index dac85a3..c5f4759 100644
--- a/tox.ini
+++ b/tox.ini
@@ -10,3 +10,14 @@ envlist = py26, py27, py32, py33, pypy
commands = py.test {posargs}
deps =
pytest
+
+[py2]
+deps =
+ {[testenv]deps}
+ {toxinidir}/pies2overrides
+
+[testenv:py26]
+deps = {[py2]deps}
+
+[testenv:py27]
+deps = {[py2]deps}