summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorJonathan Huot <JonathanHuot@users.noreply.github.com>2018-12-17 15:20:10 +0100
committerGitHub <noreply@github.com>2018-12-17 15:20:10 +0100
commit31461a0cdb47b0826e03c141a30885b9ab1b3dd5 (patch)
tree60a7d7460f44b9eeed06535bdbafd4a4d3d14ae0 /tox.ini
parent4bd39a770ce48d94ab8914463e20e9002e0b4869 (diff)
parente9c6f01bc6f89e6b90f2c9b61e6a9878d5612147 (diff)
downloadoauthlib-31461a0cdb47b0826e03c141a30885b9ab1b3dd5.tar.gz
Merge branch 'master' into 631-use-pytest
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini8
1 files changed, 7 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 05f12a6..1cac71c 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py34,py35,py36,py37,pypy,pypy3,docs,readme
+envlist = py27,py34,py35,py36,py37,pypy,pypy3,docs,readme,bandit
[testenv]
deps=
@@ -26,3 +26,9 @@ whitelist_externals=echo
commands=
python setup.py check -r -s
echo setup.py/long description is syntaxly correct
+
+[testenv:bandit]
+skipsdist=True
+deps=bandit
+commands=bandit -b bandit.json -r oauthlib/
+whitelist_externals=bandit