summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorOmer Katz <omer.drow@gmail.com>2018-12-17 16:04:26 +0200
committerGitHub <noreply@github.com>2018-12-17 16:04:26 +0200
commite9c6f01bc6f89e6b90f2c9b61e6a9878d5612147 (patch)
treecadc199546285753f61380da3eda6a8bdb2c17a0 /tox.ini
parent8de1e52fabdd9c3738a012bb88e2234d1bd06255 (diff)
downloadoauthlib-e9c6f01bc6f89e6b90f2c9b61e6a9878d5612147.tar.gz
Added bandit to CI to avoid security issues (#627)
* Added bandit to CI to avoid security issues. * Remove basepython for bandit. * Remove metrics.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini8
1 files changed, 7 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 47237d8..4893175 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py34,py35,py36,py37,pypy,pypy3,docs,readme
+envlist = py27,py34,py35,py36,py37,pypy,pypy3,docs,readme,bandit
[testenv]
deps=
@@ -27,3 +27,9 @@ whitelist_externals=echo
commands=
python setup.py check -r -s
echo setup.py/long description is syntaxly correct
+
+[testenv:bandit]
+skipsdist=True
+deps=bandit
+commands=bandit -b bandit.json -r oauthlib/
+whitelist_externals=bandit