summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorgeorge.whewell <george@bynd.com>2015-01-27 17:56:51 +0000
committergeorge.whewell <george@bynd.com>2015-01-27 17:56:51 +0000
commitdc2204572a29762ff1cce7e565406be6c4843200 (patch)
treed7f23347c366deea88fcd6d89ca7fc60449f3cfa /.travis.yml
parent09e4af26a387b3fce03f3cb1a38c6cff6a6c1af3 (diff)
downloadoauthlib-dc2204572a29762ff1cce7e565406be6c4843200.tar.gz
move test requirements to requirements-test.txt. use tox for tests on .travis.yml
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml25
1 files changed, 11 insertions, 14 deletions
diff --git a/.travis.yml b/.travis.yml
index f8c39b4..6a7359b 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,23 +1,20 @@
language: python
-python:
- - "2.6"
- - "2.7"
- - "3.2"
- - "3.3"
- - "3.4"
- - "pypy"
install:
- - if [[ $TRAVIS_PYTHON_VERSION == '2.6' ]]; then pip install --use-mirrors unittest2; fi
- - pip install nose pycrypto mock pyjwt blinker
+ - pip install tox coveralls
script:
- - nosetests -w tests
+ - tox
-after_success:
- - pip install coveralls
- - coverage run --source=oauthlib setup.py -q nosetests
- - coveralls
+env:
+ - TOXENV=py26
+ - TOXENV=py27
+ - TOXENV=py32
+ - TOXENV=py33
+ - TOXENV=py32
+ - TOXENV=pypy
+
+after_success: coveralls
branches:
only: