summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgeorge.whewell <george@bynd.com>2015-01-27 17:56:51 +0000
committergeorge.whewell <george@bynd.com>2015-01-27 17:56:51 +0000
commitdc2204572a29762ff1cce7e565406be6c4843200 (patch)
treed7f23347c366deea88fcd6d89ca7fc60449f3cfa
parent09e4af26a387b3fce03f3cb1a38c6cff6a6c1af3 (diff)
downloadoauthlib-dc2204572a29762ff1cce7e565406be6c4843200.tar.gz
move test requirements to requirements-test.txt. use tox for tests on .travis.yml
-rw-r--r--.travis.yml25
-rw-r--r--requirements-test.txt4
-rw-r--r--requirements.txt2
-rw-r--r--tox.ini5
4 files changed, 18 insertions, 18 deletions
diff --git a/.travis.yml b/.travis.yml
index f8c39b4..6a7359b 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,23 +1,20 @@
language: python
-python:
- - "2.6"
- - "2.7"
- - "3.2"
- - "3.3"
- - "3.4"
- - "pypy"
install:
- - if [[ $TRAVIS_PYTHON_VERSION == '2.6' ]]; then pip install --use-mirrors unittest2; fi
- - pip install nose pycrypto mock pyjwt blinker
+ - pip install tox coveralls
script:
- - nosetests -w tests
+ - tox
-after_success:
- - pip install coveralls
- - coverage run --source=oauthlib setup.py -q nosetests
- - coveralls
+env:
+ - TOXENV=py26
+ - TOXENV=py27
+ - TOXENV=py32
+ - TOXENV=py33
+ - TOXENV=py32
+ - TOXENV=pypy
+
+after_success: coveralls
branches:
only:
diff --git a/requirements-test.txt b/requirements-test.txt
new file mode 100644
index 0000000..a058317
--- /dev/null
+++ b/requirements-test.txt
@@ -0,0 +1,4 @@
+-r requirements.txt
+coverage==3.7.1
+nose==1.3.4
+mock==1.0.1 \ No newline at end of file
diff --git a/requirements.txt b/requirements.txt
index 7c89621..9818e25 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,5 +1,3 @@
-nose==1.3.4
-mock==1.0.1
pycrypto==2.6.1
pyjwt==0.3.2
blinker==1.3 \ No newline at end of file
diff --git a/tox.ini b/tox.ini
index f770b23..629fdc2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,8 +2,9 @@
envlist = py26,py27,py32,py33,py34,pypy
[testenv]
-deps=-rrequirements.txt
-commands=nosetests -w tests
+deps=
+ -rrequirements-test.txt
+commands=nosetests --with-coverage --cover-erase --cover-package=oauthlib -w tests
[testenv:py26]
deps=unittest2