summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSebastian Berg <sebastian@sipsolutions.net>2022-10-28 11:30:26 +0200
committerGitHub <noreply@github.com>2022-10-28 11:30:26 +0200
commita8ebbd5fdb9df3d1d2885b24e783757d747dec8e (patch)
treea1dc1bc4915e4231848553ea72dd1b4810a64786 /setup.py
parenta10b20760610be8e820f695f9889060af1a640b9 (diff)
parent69a39461de4da2bfc0e6aeeff02c73c0972a8614 (diff)
downloadnumpy-a8ebbd5fdb9df3d1d2885b24e783757d747dec8e.tar.gz
Merge pull request #22483 from mwtoews/maint-subprocess
MAINT: change subprocess arguments from Python>=3.7
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 449507334..a1e495832 100755
--- a/setup.py
+++ b/setup.py
@@ -219,8 +219,8 @@ def get_build_overrides():
return False
# will print something like '4.2.1\n'
- out = subprocess.run([cc, '-dumpversion'], stdout=subprocess.PIPE,
- stderr=subprocess.PIPE, universal_newlines=True)
+ out = subprocess.run([cc, '-dumpversion'],
+ capture_output=True, text=True)
# -std=c99 is default from this version on
if _pep440.parse(out.stdout) >= _pep440.Version('5.0'):
return False