summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMike Taves <mwtoews@gmail.com>2022-10-27 10:19:42 +1300
committerMike Taves <mwtoews@gmail.com>2022-10-27 10:38:56 +1300
commit69a39461de4da2bfc0e6aeeff02c73c0972a8614 (patch)
treecdab4df7d48c675a0961c4386dd3cd90d00dd22d /setup.py
parent13d55a3c2f016a58a6e9d6b8086f338e07c7478f (diff)
downloadnumpy-69a39461de4da2bfc0e6aeeff02c73c0972a8614.tar.gz
MAINT: change subprocess arguments from Python>=3.7
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 449507334..a1e495832 100755
--- a/setup.py
+++ b/setup.py
@@ -219,8 +219,8 @@ def get_build_overrides():
return False
# will print something like '4.2.1\n'
- out = subprocess.run([cc, '-dumpversion'], stdout=subprocess.PIPE,
- stderr=subprocess.PIPE, universal_newlines=True)
+ out = subprocess.run([cc, '-dumpversion'],
+ capture_output=True, text=True)
# -std=c99 is default from this version on
if _pep440.parse(out.stdout) >= _pep440.Version('5.0'):
return False