summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMike Taves <mwtoews@gmail.com>2022-10-28 22:37:29 +1300
committerMike Taves <mwtoews@gmail.com>2022-10-29 14:08:54 +1300
commit080cf82ebc5858ec47eff0d49bdf48b74f955274 (patch)
treec843b284d9994186ab988c7c535a895433ae9905 /setup.py
parenta8ebbd5fdb9df3d1d2885b24e783757d747dec8e (diff)
downloadnumpy-080cf82ebc5858ec47eff0d49bdf48b74f955274.tar.gz
MAINT: remove redundant open() modes and io.open() alias
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index a1e495832..687bbb1f2 100755
--- a/setup.py
+++ b/setup.py
@@ -177,11 +177,11 @@ class concat_license_files():
def __enter__(self):
"""Concatenate files and remove LICENSES_bundled.txt"""
- with open(self.f1, 'r') as f1:
+ with open(self.f1) as f1:
self.bsd_text = f1.read()
with open(self.f1, 'a') as f1:
- with open(self.f2, 'r') as f2:
+ with open(self.f2) as f2:
self.bundled_text = f2.read()
f1.write('\n\n')
f1.write(self.bundled_text)