summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorInada Naoki <songofacandy@gmail.com>2021-11-16 17:42:42 +0900
committerGitHub <noreply@github.com>2021-11-16 17:42:42 +0900
commit8e358617e77d63a391f0c0f91b3e552214f2a49a (patch)
tree9c593275d0783bb9a0741d758aed3ba1a4b08e84
parentb3f72541925cda3b018942db45a59936184727e3 (diff)
downloadmsgpack-python-8e358617e77d63a391f0c0f91b3e552214f2a49a.tar.gz
mac: Provide Universal2 wheel (#488)
* mac: Use cibuildwheel * Do not build wheel for PyPy.
-rw-r--r--.github/workflows/mac.yml51
1 files changed, 19 insertions, 32 deletions
diff --git a/.github/workflows/mac.yml b/.github/workflows/mac.yml
index 4efe2ca..85844e7 100644
--- a/.github/workflows/mac.yml
+++ b/.github/workflows/mac.yml
@@ -1,7 +1,6 @@
name: Build macOS Wheels
on:
push:
- pull_request:
create:
jobs:
@@ -12,10 +11,11 @@ jobs:
- name: Checkout
uses: actions/checkout@v1
- - name: Set up Python 3.8
+ # Python 3.9
+ - name: Set up Python 3.9
uses: actions/setup-python@v1
with:
- python-version: "3.8"
+ python-version: "3.9"
- name: Cythonize
run: |
@@ -23,66 +23,53 @@ jobs:
pip install -r requirements.txt
make cython
- - name: Build wheel
- run: |
- pip install setuptools wheel
- python setup.py bdist_wheel
+ - name: Build wheels
+ uses: pypa/cibuildwheel@v2.2.2
+ env:
+ CIBW_ARCHS_MACOS: x86_64 universal2
+ CIBW_SKIP: pp*
- name: Run test
run: |
+ ls wheelhouse/
pip install pytest
- pip install -v msgpack --only-binary :all: -f dist/ --no-index
+ pip install -v msgpack --only-binary :all: -f wheelhouse/ --no-index
pytest -v test
-
+ # Python 3.10
- name: Set up Python 3.10
uses: actions/setup-python@v1
with:
python-version: "3.10"
- - name: Build wheel
- run: |
- pip install setuptools wheel
- python setup.py bdist_wheel
-
- name: Run test
run: |
pip install pytest
- pip install -v msgpack --only-binary :all: -f dist/ --no-index
+ pip install -v msgpack --only-binary :all: -f wheelhouse/ --no-index
pytest -v test
-
- - name: Set up Python 3.9
+ # Python 3.8
+ - name: Set up Python 3.8
uses: actions/setup-python@v1
with:
- python-version: "3.9"
-
- - name: Build wheel
- run: |
- pip install setuptools wheel
- python setup.py bdist_wheel
+ python-version: "3.8"
- name: Run test
run: |
pip install pytest
- pip install -v msgpack --only-binary :all: -f dist/ --no-index
+ pip install -v msgpack --only-binary :all: -f wheelhouse/ --no-index
pytest -v test
-
+ # Python 3.7
- name: Set up Python 3.7
uses: actions/setup-python@v1
with:
python-version: "3.7"
- - name: Build wheel
- run: |
- pip install setuptools wheel
- python setup.py bdist_wheel
-
- name: Run test
run: |
pip install pytest
- pip install -v msgpack --only-binary :all: -f dist/ --no-index
+ pip install -v msgpack --only-binary :all: -f wheelhouse/ --no-index
pytest -v test
@@ -90,4 +77,4 @@ jobs:
uses: actions/upload-artifact@v1
with:
name: macos-wheels
- path: ./dist/
+ path: ./wheelhouse/