summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorInada Naoki <songofacandy@gmail.com>2021-11-16 16:19:47 +0900
committerGitHub <noreply@github.com>2021-11-16 16:19:47 +0900
commitb3f72541925cda3b018942db45a59936184727e3 (patch)
treecc292c34c376f7ee2065fc215a1ba322702c45f5
parent9b84e490e7c78ac9bbd76dcf9ce71c1d0c978d81 (diff)
downloadmsgpack-python-b3f72541925cda3b018942db45a59936184727e3.tar.gz
Support Python 3.10 and Drop Python 3.5 (#487)
* linux: Use manylinux2014 * mac: Drop Python 3.6 too
-rw-r--r--.github/workflows/linux.yml11
-rw-r--r--.github/workflows/mac.yml12
-rw-r--r--.github/workflows/windows.yaml14
-rw-r--r--Makefile4
-rw-r--r--docker/buildwheel.sh4
-rw-r--r--docker/shared.env2
-rwxr-xr-xsetup.py4
7 files changed, 38 insertions, 13 deletions
diff --git a/.github/workflows/linux.yml b/.github/workflows/linux.yml
index f9707b1..811bc13 100644
--- a/.github/workflows/linux.yml
+++ b/.github/workflows/linux.yml
@@ -47,6 +47,17 @@ jobs:
pytest -v test
+ - name: Set up Python 3.10
+ uses: actions/setup-python@v1
+ with:
+ python-version: "3.10"
+
+ - name: Run test (3.10)
+ run: |
+ pip install pytest
+ pip install -v msgpack --only-binary :all: --no-index -f dist/wheelhouse
+ pytest -v test
+
- name: Set up Python 3.9
uses: actions/setup-python@v1
with:
diff --git a/.github/workflows/mac.yml b/.github/workflows/mac.yml
index 78d944c..4efe2ca 100644
--- a/.github/workflows/mac.yml
+++ b/.github/workflows/mac.yml
@@ -35,10 +35,10 @@ jobs:
pytest -v test
- - name: Set up Python 3.9
+ - name: Set up Python 3.10
uses: actions/setup-python@v1
with:
- python-version: "3.9"
+ python-version: "3.10"
- name: Build wheel
run: |
@@ -52,10 +52,10 @@ jobs:
pytest -v test
- - name: Set up Python 3.7
+ - name: Set up Python 3.9
uses: actions/setup-python@v1
with:
- python-version: "3.7"
+ python-version: "3.9"
- name: Build wheel
run: |
@@ -69,10 +69,10 @@ jobs:
pytest -v test
- - name: Set up Python 3.6
+ - name: Set up Python 3.7
uses: actions/setup-python@v1
with:
- python-version: "3.6"
+ python-version: "3.7"
- name: Build wheel
run: |
diff --git a/.github/workflows/windows.yaml b/.github/workflows/windows.yaml
index 139a5a6..debe074 100644
--- a/.github/workflows/windows.yaml
+++ b/.github/workflows/windows.yaml
@@ -77,6 +77,20 @@ jobs:
run: |
ci/runtests.sh
+ - name: Python 3.10 (amd64)
+ env:
+ PYTHON: "py -3.10-64"
+ shell: bash
+ run: |
+ ci/runtests.sh
+
+ - name: Python 3.10 (x86)
+ env:
+ PYTHON: "py -3.10-32"
+ shell: bash
+ run: |
+ ci/runtests.sh
+
- name: Upload Wheels
uses: actions/upload-artifact@v1
with:
diff --git a/Makefile b/Makefile
index 6f29aed..b50fa80 100644
--- a/Makefile
+++ b/Makefile
@@ -36,8 +36,8 @@ update-docker:
.PHONY: linux-wheel
linux-wheel:
- docker run --rm -v `pwd`:/project -w /project quay.io/pypa/manylinux1_i686 bash docker/buildwheel.sh
- docker run --rm -v `pwd`:/project -w /project quay.io/pypa/manylinux1_x86_64 bash docker/buildwheel.sh
+ docker run --rm -v `pwd`:/project -w /project quay.io/pypa/manylinux2014_i686 bash docker/buildwheel.sh
+ docker run --rm -v `pwd`:/project -w /project quay.io/pypa/manylinux2014_x86_64 bash docker/buildwheel.sh
.PHONY: linux-arm64-wheel
linux-arm64-wheel:
diff --git a/docker/buildwheel.sh b/docker/buildwheel.sh
index 89a2570..ff34139 100644
--- a/docker/buildwheel.sh
+++ b/docker/buildwheel.sh
@@ -7,10 +7,12 @@ set -e -x
ARCH=`uname -p`
echo "arch=$ARCH"
+ls /opt/python
+
for V in "${PYTHON_VERSIONS[@]}"; do
PYBIN=/opt/python/$V/bin
rm -rf build/ # Avoid lib build by narrow Python is used by wide python
- $PYBIN/python setup.py bdist_wheel
+ $PYBIN/python -m build -w
done
cd dist
diff --git a/docker/shared.env b/docker/shared.env
index 3601a07..80274ac 100644
--- a/docker/shared.env
+++ b/docker/shared.env
@@ -1,7 +1,7 @@
PYTHON_VERSIONS=(
+ cp310-cp310
cp39-cp39
cp38-cp38
cp37-cp37m
cp36-cp36m
- cp35-cp35m
)
diff --git a/setup.py b/setup.py
index 751abff..01f125f 100755
--- a/setup.py
+++ b/setup.py
@@ -125,14 +125,12 @@ setup(
},
license="Apache 2.0",
classifiers=[
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Intended Audience :: Developers",