summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Tang <henryykt@gmail.com>2020-03-27 17:07:17 +0800
committerAsif Saif Uddin <auvipy@gmail.com>2020-03-27 16:44:53 +0600
commit7c0466e1c1a5820a2f9c52ec0314de0d3354e7d8 (patch)
tree1689ce0c8b888235885bb3040c28307e8dd8e64c
parent0cc779cd5bd61fa39bed33a2cdfca7ba83d96f5d (diff)
downloadlibrabbitmq-7c0466e1c1a5820a2f9c52ec0314de0d3354e7d8.tar.gz
Skip cp27-cp27mu builds (due to undefined symbol: PyUnicodeUCS2_AsASCIIString)
-rw-r--r--Makefile1
-rwxr-xr-xbuild-manylinux1-wheels.sh22
-rw-r--r--setup.py5
3 files changed, 18 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index e7538a1..0615af3 100644
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,7 @@ rabbitmq-c: submodules
rabbitmq-clean:
+ -(rm -rf $(RABBIT_DIR)/build || true)
-(cd $(RABBIT_DIR) && make clean || echo "warning... rabbitmq-clean failed")
rabbitmq-distclean:
diff --git a/build-manylinux1-wheels.sh b/build-manylinux1-wheels.sh
index b111482..9c534de 100755
--- a/build-manylinux1-wheels.sh
+++ b/build-manylinux1-wheels.sh
@@ -5,29 +5,35 @@ set -e -x
# Install system packages required by our library
yum install -y cmake openssl-devel gcc automake
-# Ensure a fresh build of rabbitmq-c.
-(cd /workspace && make submodules)
-rm -rf /workspace/rabbitmq-c/build
-(cd /workspace && make rabbitmq-c)
-
# Compile wheels
for PYBIN in /opt/python/*/bin; do
+ # cp27-cp27mu builds fail with: undefined symbol: PyUnicodeUCS2_AsASCIIString
+ if [[ "${PYBIN}" == *"cp27-cp27mu"* ]]; then
+ continue
+ fi
+
+ # Ensure a fresh build of rabbitmq-c.
+ rm -rf /workspace/rabbitmq-c/build
(cd /workspace && ${PYBIN}/python setup.py install)
${PYBIN}/pip wheel /workspace/ -w wheelhouse/
done
# Bundle external shared libraries into the wheels
-#ls wheelhouse/*
for whl in wheelhouse/*linux*.whl; do
auditwheel repair $whl -w /workspace/wheelhouse/
done
# Install packages and test
for PYBIN in /opt/python/*/bin/; do
- # vine 5.0.0a1 breaks python2
+ if [[ "${PYBIN}" == *"cp27-cp27mu"* ]]; then
+ continue
+ fi
+
+ # amqp 5.0.0a1 and vine 5.0.0a1 breaks python2
# https://github.com/celery/vine/issues/34
- if [[ "$PYBIN" == *"python/cp2"* ]]; then
+ if [[ "${PYBIN}" == *"python/cp2"* ]]; then
${PYBIN}/pip install --force-reinstall "vine==1.3.0"
+ ${PYBIN}/pip install --force-reinstall "amqp==2.5.2"
fi
${PYBIN}/pip install librabbitmq -f /workspace/wheelhouse
diff --git a/setup.py b/setup.py
index 6985565..e3fee76 100644
--- a/setup.py
+++ b/setup.py
@@ -155,8 +155,9 @@ def create_builder():
return
os.chdir('build')
- if os.system(cmake + ' ..'):
- return
+ if not os.path.isfile('Makefile'):
+ if os.system(cmake + ' ..'):
+ return
if os.system(make + ' rabbitmq rabbitmq-static'):
return