summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Tang <henryykt@gmail.com>2020-03-27 15:24:36 +0800
committerAsif Saif Uddin <auvipy@gmail.com>2020-03-27 13:59:23 +0600
commit0cc779cd5bd61fa39bed33a2cdfca7ba83d96f5d (patch)
tree4a3fc27492e15dc547ecce0a04e5fc6bf431dc75
parentea29f3d52fe2260756c340302e2e73081cfc9400 (diff)
downloadlibrabbitmq-0cc779cd5bd61fa39bed33a2cdfca7ba83d96f5d.tar.gz
Ensure a fresh build of rabbitmq-c before building wheels
Fix vine install
-rwxr-xr-xbuild-manylinux1-wheels.sh7
1 files changed, 6 insertions, 1 deletions
diff --git a/build-manylinux1-wheels.sh b/build-manylinux1-wheels.sh
index 664075c..b111482 100755
--- a/build-manylinux1-wheels.sh
+++ b/build-manylinux1-wheels.sh
@@ -5,6 +5,11 @@ set -e -x
# Install system packages required by our library
yum install -y cmake openssl-devel gcc automake
+# Ensure a fresh build of rabbitmq-c.
+(cd /workspace && make submodules)
+rm -rf /workspace/rabbitmq-c/build
+(cd /workspace && make rabbitmq-c)
+
# Compile wheels
for PYBIN in /opt/python/*/bin; do
(cd /workspace && ${PYBIN}/python setup.py install)
@@ -22,7 +27,7 @@ for PYBIN in /opt/python/*/bin/; do
# vine 5.0.0a1 breaks python2
# https://github.com/celery/vine/issues/34
if [[ "$PYBIN" == *"python/cp2"* ]]; then
- ${PYBIN}/pip install -f "vine==1.3.0"
+ ${PYBIN}/pip install --force-reinstall "vine==1.3.0"
fi
${PYBIN}/pip install librabbitmq -f /workspace/wheelhouse