summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDominic <yobmod@gmail.com>2021-07-24 09:55:53 +0100
committerGitHub <noreply@github.com>2021-07-24 09:55:53 +0100
commitfb21782089dbbb43b2f8cf36ce3e732558032aff (patch)
tree6a93dcbf3f13bf7fc08e8aeabdac6e1d958d4980 /pyproject.toml
parent2df0381718a4ba18394e68b40e352fa7528e9018 (diff)
downloadgitpython-fb21782089dbbb43b2f8cf36ce3e732558032aff.tar.gz
Add build system to pyproject.toml
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 79e62840..94f74793 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,7 @@
+[build-system]
+requires = ["setuptools", "wheel"]
+build-backend = "setuptools.build_meta"
+
[tool.pytest.ini_options]
python_files = 'test_*.py'
testpaths = 'test' # space seperated list of paths from root e.g test tests doc/testing