summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2021-07-14 07:43:41 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2021-07-14 07:45:05 +0800
commitcf9b511ac3386910b695fa6482b7488802f77eb2 (patch)
tree52a90b1f3e841d3e73d74d70ab1170b5388ee1aa /Makefile
parent63f5541c183a22b0aff012c9b0c7df76142d63fa (diff)
downloadgitpython-cf9b511ac3386910b695fa6482b7488802f77eb2.tar.gz
Remove docker and appveyor configuration files
These weren't used by CI nor were they regularly tested. If somebody misses something, we can bring them back of course. This cleanup was triggered with the switch to pytest, and I wanted to remove everything that was present just for nosetest.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 2 insertions, 16 deletions
diff --git a/Makefile b/Makefile
index f5d8a108..fe82a694 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-.PHONY: all clean release force_release docker-build test nose-pdb
+.PHONY: all clean release force_release
all:
@grep -Ee '^[a-z].*:' Makefile | cut -d: -f1 | grep -vF all
@@ -17,18 +17,4 @@ release: clean
force_release: clean
git push --tags origin main
python3 setup.py sdist bdist_wheel
- twine upload -s -i 27C50E7F590947D7273A741E85194C08421980C9 dist/*
-
-docker-build:
- docker build --quiet -t gitpython:xenial -f Dockerfile .
-
-test: docker-build
- # NOTE!!!
- # NOTE!!! If you are not running from main or have local changes then tests will fail
- # NOTE!!!
- docker run --rm -v ${CURDIR}:/src -w /src -t gitpython:xenial tox
-
-nose-pdb: docker-build
- # run tests under nose and break on error or failure into python debugger
- # HINT: set PYVER to "pyXX" to change from the default of py37 to pyXX for nose tests
- docker run --rm --env PYVER=${PYVER} -v ${CURDIR}:/src -w /src -it gitpython:xenial /bin/bash dockernose.sh
+ twine upload -s -i 27C50E7F590947D7273A741E85194C08421980C9 dist/* \ No newline at end of file