summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2021-07-14 07:43:41 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2021-07-14 07:45:05 +0800
commitcf9b511ac3386910b695fa6482b7488802f77eb2 (patch)
tree52a90b1f3e841d3e73d74d70ab1170b5388ee1aa
parent63f5541c183a22b0aff012c9b0c7df76142d63fa (diff)
downloadgitpython-cf9b511ac3386910b695fa6482b7488802f77eb2.tar.gz
Remove docker and appveyor configuration files
These weren't used by CI nor were they regularly tested. If somebody misses something, we can bring them back of course. This cleanup was triggered with the switch to pytest, and I wanted to remove everything that was present just for nosetest.
-rw-r--r--.appveyor.yml73
-rw-r--r--.dockerignore2
-rw-r--r--.github/workflows/pythonpackage.yml11
-rw-r--r--Dockerfile84
-rw-r--r--Makefile18
-rwxr-xr-xdockernose.sh10
6 files changed, 3 insertions, 195 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
deleted file mode 100644
index 833f5c7b..00000000
--- a/.appveyor.yml
+++ /dev/null
@@ -1,73 +0,0 @@
-# UNUSED, only for reference. If windows testing is needed, please add that to github actions
-# CI on Windows via appveyor
-environment:
- GIT_DAEMON_PATH: "C:\\Program Files\\Git\\mingw64\\libexec\\git-core"
- CYGWIN_GIT_PATH: "C:\\cygwin\\bin;%GIT_DAEMON_PATH%"
- CYGWIN64_GIT_PATH: "C:\\cygwin64\\bin;%GIT_DAEMON_PATH%"
-
- matrix:
- - PYTHON: "C:\\Python36-x64"
- PYTHON_VERSION: "3.6"
- GIT_PATH: "%GIT_DAEMON_PATH%"
- - PYTHON: "C:\\Python37-x64"
- PYTHON_VERSION: "3.7"
- GIT_PATH: "%GIT_DAEMON_PATH%"
-
-matrix:
- allow_failures:
- - MAYFAIL: "yes"
-install:
- - set PATH=%PYTHON%;%PYTHON%\Scripts;%GIT_PATH%;%PATH%
-
- ## Print configuration for debugging.
- #
- - |
- echo %PATH%
- uname -a
- git --version
- where git git-daemon python pip pip3 pip34 sh
- python --version
- python -c "import struct; print(struct.calcsize('P') * 8)"
-
- - IF "%IS_CONDA%" == "yes" (
- conda info -a &
- conda install --yes --quiet pip
- )
- - pip install -r requirements.txt
- - pip install -r test-requirements.txt
- - pip install codecov
-
- ## Copied from `init-tests-after-clone.sh`.
- #
- - |
- git submodule update --init --recursive
- git fetch --tags
- git tag __testing_point__
- git checkout master || git checkout -b master
- git reset --hard HEAD~1
- git reset --hard HEAD~1
- git reset --hard HEAD~1
- git reset --hard __testing_point__
-
- ## For commits performed with the default user.
- - |
- git config --global user.email "travis@ci.com"
- git config --global user.name "Travis Runner"
-
- - pip install -e .
-
-build: false
-
-test_script:
- - nosetests -v
-
-on_success:
- - IF "%PYTHON_VERSION%" == "3.6" IF NOT "%IS_CYGWIN%" == "yes" (codecov)
-
-# Enable this to be able to login to the build worker. You can use the
-# `remmina` program in Ubuntu, use the login information that the line below
-# prints into the log.
-#on_finish:
-# - |
-# echo "Running on_finish to establish connection back to the instance"
-# - ps: $blockRdp = $true; iex ((new-object net.webclient).DownloadString('https://raw.githubusercontent.com/appveyor/ci/master/scripts/enable-rdp.ps1'))
diff --git a/.dockerignore b/.dockerignore
deleted file mode 100644
index b59962d2..00000000
--- a/.dockerignore
+++ /dev/null
@@ -1,2 +0,0 @@
-.git/
-.tox/
diff --git a/.github/workflows/pythonpackage.yml b/.github/workflows/pythonpackage.yml
index e575a016..115610f3 100644
--- a/.github/workflows/pythonpackage.yml
+++ b/.github/workflows/pythonpackage.yml
@@ -68,13 +68,4 @@ jobs:
run: |
set -x
pip install -r doc/requirements.txt
- make -C doc html
-
- # - name: Test with nose
- # run: |
- # set -x
- # pip install nose
- # nosetests -v --with-coverage
- # continue-on-error: false
-
-
+ make -C doc html \ No newline at end of file
diff --git a/Dockerfile b/Dockerfile
deleted file mode 100644
index f2d7e22f..00000000
--- a/Dockerfile
+++ /dev/null
@@ -1,84 +0,0 @@
-#
-# Contributed by: James E. King III (@jeking3) <jking@apache.org>
-#
-# This Dockerfile creates an Ubuntu Xenial build environment
-# that can run the same test suite as Travis CI.
-#
-
-FROM ubuntu:xenial
-
-# Metadata
-LABEL maintainer="jking@apache.org"
-LABEL description="CI environment for testing GitPython"
-
-ENV CONTAINER_USER=user
-ENV DEBIAN_FRONTEND noninteractive
-
-RUN apt-get update && \
- apt-get install -y --no-install-recommends \
- add-apt-key \
- apt \
- apt-transport-https \
- apt-utils \
- ca-certificates \
- curl \
- git \
- net-tools \
- openssh-client \
- sudo \
- vim \
- wget
-
-RUN add-apt-key -v 6A755776 -k keyserver.ubuntu.com && \
- add-apt-key -v E1DF1F24 -k keyserver.ubuntu.com && \
- echo "deb http://ppa.launchpad.net/git-core/ppa/ubuntu xenial main" >> /etc/apt/sources.list && \
- echo "deb http://ppa.launchpad.net/deadsnakes/ppa/ubuntu xenial main" >> /etc/apt/sources.list && \
- apt-get update && \
- apt-get install -y --install-recommends git python2.7 python3.4 python3.5 python3.6 python3.7 && \
- update-alternatives --install /usr/bin/python3 python3 /usr/bin/python2.7 27 && \
- update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.4 34 && \
- update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.5 35 && \
- update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.6 36 && \
- update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.7 37
-
-RUN curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py && \
- python3 get-pip.py && \
- pip3 install tox
-
-# Clean up
-RUN rm -rf /var/cache/apt/* && \
- rm -rf /var/lib/apt/lists/* && \
- rm -rf /tmp/* && \
- rm -rf /var/tmp/*
-
-#################################################################
-# Build as a regular user
-# Credit: https://github.com/delcypher/docker-ubuntu-cxx-dev/blob/master/Dockerfile
-# License: None specified at time of import
-# Add non-root user for container but give it sudo access.
-# Password is the same as the username
-RUN useradd -m ${CONTAINER_USER} && \
- echo ${CONTAINER_USER}:${CONTAINER_USER} | chpasswd && \
- echo "${CONTAINER_USER} ALL=(root) ALL" >> /etc/sudoers
-RUN chsh --shell /bin/bash ${CONTAINER_USER}
-USER ${CONTAINER_USER}
-#################################################################
-
-# The test suite will not tolerate running against a branch that isn't "master", so
-# check out the project to a well-known location that can be used by the test suite.
-# This has the added benefit of protecting the local repo fed into the container
-# as a volume from getting destroyed by a bug exposed by the test suite. :)
-ENV TRAVIS=ON
-RUN git clone --recursive https://github.com/gitpython-developers/GitPython.git /home/${CONTAINER_USER}/testrepo && \
- cd /home/${CONTAINER_USER}/testrepo && \
- ./init-tests-after-clone.sh
-ENV GIT_PYTHON_TEST_GIT_REPO_BASE=/home/${CONTAINER_USER}/testrepo
-ENV TRAVIS=
-
-# Ensure any local pip installations get on the path
-ENV PATH=/home/${CONTAINER_USER}/.local/bin:${PATH}
-
-# Set the global default git user to be someone non-descript
-RUN git config --global user.email ci@gitpython.org && \
- git config --global user.name "GitPython CI User"
-
diff --git a/Makefile b/Makefile
index f5d8a108..fe82a694 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-.PHONY: all clean release force_release docker-build test nose-pdb
+.PHONY: all clean release force_release
all:
@grep -Ee '^[a-z].*:' Makefile | cut -d: -f1 | grep -vF all
@@ -17,18 +17,4 @@ release: clean
force_release: clean
git push --tags origin main
python3 setup.py sdist bdist_wheel
- twine upload -s -i 27C50E7F590947D7273A741E85194C08421980C9 dist/*
-
-docker-build:
- docker build --quiet -t gitpython:xenial -f Dockerfile .
-
-test: docker-build
- # NOTE!!!
- # NOTE!!! If you are not running from main or have local changes then tests will fail
- # NOTE!!!
- docker run --rm -v ${CURDIR}:/src -w /src -t gitpython:xenial tox
-
-nose-pdb: docker-build
- # run tests under nose and break on error or failure into python debugger
- # HINT: set PYVER to "pyXX" to change from the default of py37 to pyXX for nose tests
- docker run --rm --env PYVER=${PYVER} -v ${CURDIR}:/src -w /src -it gitpython:xenial /bin/bash dockernose.sh
+ twine upload -s -i 27C50E7F590947D7273A741E85194C08421980C9 dist/* \ No newline at end of file
diff --git a/dockernose.sh b/dockernose.sh
deleted file mode 100755
index c9227118..00000000
--- a/dockernose.sh
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/usr/bin/env bash
-set -ex
-if [ -z "${PYVER}" ]; then
- PYVER=py37
-fi
-
-# remember to use "-s" if you inject pdb.set_trace() as this disables nosetests capture of streams
-
-tox -e ${PYVER} --notest
-PYTHONPATH=/src/.tox/${PYVER}/lib/python*/site-packages /src/.tox/${PYVER}/bin/nosetests --pdb $*