summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarmon <Harmon758@gmail.com>2020-02-23 09:13:36 -0600
committerHarmon <Harmon758@gmail.com>2020-02-23 09:33:21 -0600
commit253dfe7092f83229d9e99059e7c51f678a557fd2 (patch)
tree6b05e2298492678dfa0dbb6361b27e2237e292e6
parent74aef73b0dd1f97b89f95f67500ae9c4c405ff15 (diff)
downloadgitdb-253dfe7092f83229d9e99059e7c51f678a557fd2.tar.gz
v4.0.14.0.1
-rw-r--r--doc/source/changes.rst10
-rw-r--r--gitdb/__init__.py2
m---------gitdb/ext/smmap0
-rw-r--r--requirements.txt2
-rwxr-xr-xsetup.py6
5 files changed, 15 insertions, 5 deletions
diff --git a/doc/source/changes.rst b/doc/source/changes.rst
index ac4b477..236b954 100644
--- a/doc/source/changes.rst
+++ b/doc/source/changes.rst
@@ -2,6 +2,16 @@
Changelog
#########
+*****
+4.0.1
+*****
+
+* Switched back to the gitdb package name on PyPI and fixed the gitdb2 mirror package
+ (`#59 <https://github.com/gitpython-developers/gitdb/issues/59>`_)
+* Switched back to require smmap package and fixed version requirement to >= 3.0.1, < 4
+ (`#59 <https://github.com/gitpython-developers/gitdb/issues/59>`_)
+* Updated smmap submodule
+
***********
3.0.3.post1
***********
diff --git a/gitdb/__init__.py b/gitdb/__init__.py
index b6a0341..5d68ccb 100644
--- a/gitdb/__init__.py
+++ b/gitdb/__init__.py
@@ -29,7 +29,7 @@ _init_externals()
__author__ = "Sebastian Thiel"
__contact__ = "byronimo@gmail.com"
__homepage__ = "https://github.com/gitpython-developers/gitdb"
-version_info = (3, 0, 3, "post1")
+version_info = (4, 0, 1)
__version__ = '.'.join(str(i) for i in version_info)
diff --git a/gitdb/ext/smmap b/gitdb/ext/smmap
-Subproject a0060cfdc9166bb0b3104e8015faf0689aa6daf
+Subproject d076f665dae16bd03eeb9df862860d54968eda8
diff --git a/requirements.txt b/requirements.txt
index 92b8872..b6ccf50 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1 +1 @@
-smmap2>=2,<3
+smmap>=3.0.1,<4
diff --git a/setup.py b/setup.py
index b79dcb2..7617583 100755
--- a/setup.py
+++ b/setup.py
@@ -7,11 +7,11 @@ from setuptools import setup
__author__ = "Sebastian Thiel"
__contact__ = "byronimo@gmail.com"
__homepage__ = "https://github.com/gitpython-developers/gitdb"
-version_info = (3, 0, 3, "post1")
+version_info = (4, 0, 1)
__version__ = '.'.join(str(i) for i in version_info)
setup(
- name="gitdb2",
+ name="gitdb",
version=__version__,
description="Git Object Database",
author=__author__,
@@ -20,7 +20,7 @@ setup(
packages=('gitdb', 'gitdb.db', 'gitdb.utils', 'gitdb.test'),
license="BSD License",
zip_safe=False,
- install_requires=['smmap2>=2,<3'],
+ install_requires=['smmap>=3.0.1,<4'],
long_description="""GitDB is a pure-Python git object database""",
python_requires='>=3.4',
# See https://pypi.python.org/pypi?%3Aaction=list_classifiers