summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJeremy Stanley <fungi@yuggoth.org>2014-02-11 20:54:56 +0000
committerJeremy Stanley <fungi@yuggoth.org>2014-02-11 21:20:38 +0000
commit9c63d508489cf6348e9c63d42e045d4c5d00cf11 (patch)
treec62af3e40f28eb86d831d180e4b1107e48cdcef4 /setup.py
parenta8951ef927ec9aab093b4915af3fc5e60fdb2a55 (diff)
downloadgear-9c63d508489cf6348e9c63d42e045d4c5d00cf11.tar.gz
Solve hacking/pbr requirements conflict
* requirements.txt: Add an empty line making it more clear that pbr has to appear first in the requirements list, before other entries. Also specify a newer required minimum pbr since the old one had bugs and ought to be avoided. * setup.py: Stop declaring the pbr version range here, since it's handled separately by the requirements list. * test-requirements.txt: Allow newer hacking with solvable pbr second-order requirement and move it to the top of the list so that it gets satisfied before other test requirements. Change-Id: I4f80094c719f43a1261091263ccf60eefe5d9af1
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f429ba9..c0a24ea 100755
--- a/setup.py
+++ b/setup.py
@@ -17,5 +17,5 @@
import setuptools
setuptools.setup(
- setup_requires=['pbr>=0.5.21,<1.0'],
+ setup_requires=['pbr'],
pbr=True)