summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Stanley <fungi@yuggoth.org>2014-02-11 20:54:56 +0000
committerJeremy Stanley <fungi@yuggoth.org>2014-02-11 21:20:38 +0000
commit9c63d508489cf6348e9c63d42e045d4c5d00cf11 (patch)
treec62af3e40f28eb86d831d180e4b1107e48cdcef4
parenta8951ef927ec9aab093b4915af3fc5e60fdb2a55 (diff)
downloadgear-9c63d508489cf6348e9c63d42e045d4c5d00cf11.tar.gz
Solve hacking/pbr requirements conflict
* requirements.txt: Add an empty line making it more clear that pbr has to appear first in the requirements list, before other entries. Also specify a newer required minimum pbr since the old one had bugs and ought to be avoided. * setup.py: Stop declaring the pbr version range here, since it's handled separately by the requirements list. * test-requirements.txt: Allow newer hacking with solvable pbr second-order requirement and move it to the top of the list so that it gets satisfied before other test requirements. Change-Id: I4f80094c719f43a1261091263ccf60eefe5d9af1
-rw-r--r--requirements.txt3
-rwxr-xr-xsetup.py2
-rw-r--r--test-requirements.txt3
3 files changed, 5 insertions, 3 deletions
diff --git a/requirements.txt b/requirements.txt
index 4f48485..37d1b8c 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,3 +1,4 @@
-pbr>=0.5.21,<1.0
+pbr>=0.6,<1.0
+
extras
python-daemon
diff --git a/setup.py b/setup.py
index f429ba9..c0a24ea 100755
--- a/setup.py
+++ b/setup.py
@@ -17,5 +17,5 @@
import setuptools
setuptools.setup(
- setup_requires=['pbr>=0.5.21,<1.0'],
+ setup_requires=['pbr'],
pbr=True)
diff --git a/test-requirements.txt b/test-requirements.txt
index c75f664..55aeb1b 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -1,7 +1,8 @@
+hacking>=0.5.3,<0.8
+
coverage>=3.6
discover
fixtures>=0.3.12
-hacking>=0.5.3,<0.6
python-subunit
statsd>=1.0.0,<3.0
sphinx>=1.1.2,<1.2