summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Mayer <entroP@gmail.com>2023-03-27 09:32:22 +0200
committerGitHub <noreply@github.com>2023-03-27 09:32:22 +0200
commit9a22df723efa0ff573ab143367f96f0e12a07750 (patch)
tree1478c8259b6d9224fb154963076eb6c17b58eb5d
parentfbc2905e2ca92c59f93b7831751b088d1dff920d (diff)
parent759f549f22027bd2df49b960adb058f018eacf9e (diff)
downloadfeedgenerator-9a22df723efa0ff573ab143367f96f0e12a07750.tar.gz
Merge pull request #35 from hugovk/add-3.11
-rw-r--r--.github/workflows/main.yml6
-rw-r--r--.pre-commit-config.yaml6
-rw-r--r--LICENSE1
-rw-r--r--setup.py5
-rw-r--r--tox.ini6
5 files changed, 13 insertions, 11 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index e6ee180..83b584e 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -11,12 +11,12 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.6, 3.7, 3.8, 3.9]
+ python-version: ["3.7", "3.8", "3.9", "3.10", "3.11", "3.12-dev"]
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
- name: Set up Python ${{ matrix.python-version }}
- uses: actions/setup-python@v1
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python-version }}
- name: Upgrade Pip
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 049ecc2..38c4a68 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -1,7 +1,7 @@
---
repos:
- repo: https://github.com/pre-commit/pre-commit-hooks
- rev: v4.0.1
+ rev: v4.4.0
hooks:
- id: check-added-large-files
- id: check-ast
@@ -15,7 +15,7 @@ repos:
- id: trailing-whitespace
- repo: https://github.com/asottile/pyupgrade
- rev: v2.23.3
+ rev: v3.2.3
hooks:
- id: pyupgrade
- args: [--py36-plus]
+ args: [--py37-plus]
diff --git a/LICENSE b/LICENSE
index 51e78b9..5f4f225 100644
--- a/LICENSE
+++ b/LICENSE
@@ -25,4 +25,3 @@ LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
diff --git a/setup.py b/setup.py
index 36e8efb..4baa904 100644
--- a/setup.py
+++ b/setup.py
@@ -20,10 +20,11 @@ CLASSIFIERS = ['Development Status :: 5 - Production/Stable',
'License :: OSI Approved :: BSD License',
'Operating System :: OS Independent',
'Programming Language :: Python',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
'Topic :: Internet :: WWW/HTTP',
'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
'Topic :: Software Development :: Libraries :: Python Modules',
@@ -46,7 +47,7 @@ setup(
packages=PACKAGES,
test_suite=TEST_SUITE,
install_requires=REQUIRES,
- python_requires='>=3.6',
+ python_requires='>=3.7',
# metadata for upload to PyPI
author=AUTHOR,
author_email=AUTHOR_EMAIL,
diff --git a/tox.ini b/tox.ini
index 8528187..1f15d47 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,12 +1,14 @@
[tox]
-envlist = py{3.6,3.7,3.8,3.9}
+envlist = py{3.7,3.8,3.9,3.10,3.11,3.12}
[testenv]
basepython =
- py3.6: python3.6
py3.7: python3.7
py3.8: python3.8
py3.9: python3.9
+ py3.10: python3.10
+ py3.11: python3.11
+ py3.12: python3.12
commands =
{envpython} --version
pytest