summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2022-12-02 18:43:50 +0200
committerHugo van Kemenade <hugovk@users.noreply.github.com>2022-12-02 18:43:50 +0200
commit759f549f22027bd2df49b960adb058f018eacf9e (patch)
treeaa004904c8dbb69369b8b00d4bc8623587199036
parent0d4118d94964a87701b5a266f0ed816cf7fe0377 (diff)
downloadfeedgenerator-759f549f22027bd2df49b960adb058f018eacf9e.tar.gz
Drop support for EOL Python 3.6
-rw-r--r--.github/workflows/main.yml2
-rw-r--r--.pre-commit-config.yaml2
-rw-r--r--setup.py3
-rw-r--r--tox.ini3
4 files changed, 4 insertions, 6 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index 96f1bd5..83b584e 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -11,7 +11,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: ["3.6", "3.7", "3.8", "3.9", "3.10", "3.11", "3.12-dev"]
+ python-version: ["3.7", "3.8", "3.9", "3.10", "3.11", "3.12-dev"]
steps:
- uses: actions/checkout@v3
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 338bbff..38c4a68 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -18,4 +18,4 @@ repos:
rev: v3.2.3
hooks:
- id: pyupgrade
- args: [--py36-plus]
+ args: [--py37-plus]
diff --git a/setup.py b/setup.py
index 676a960..4baa904 100644
--- a/setup.py
+++ b/setup.py
@@ -20,7 +20,6 @@ CLASSIFIERS = ['Development Status :: 5 - Production/Stable',
'License :: OSI Approved :: BSD License',
'Operating System :: OS Independent',
'Programming Language :: Python',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
@@ -48,7 +47,7 @@ setup(
packages=PACKAGES,
test_suite=TEST_SUITE,
install_requires=REQUIRES,
- python_requires='>=3.6',
+ python_requires='>=3.7',
# metadata for upload to PyPI
author=AUTHOR,
author_email=AUTHOR_EMAIL,
diff --git a/tox.ini b/tox.ini
index c2264be..1f15d47 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,9 +1,8 @@
[tox]
-envlist = py{3.6,3.7,3.8,3.9,3.10,3.11,3.12}
+envlist = py{3.7,3.8,3.9,3.10,3.11,3.12}
[testenv]
basepython =
- py3.6: python3.6
py3.7: python3.7
py3.8: python3.8
py3.9: python3.9