summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHubert Kario <hkario@redhat.com>2022-06-25 18:42:48 +0200
committerGitHub <noreply@github.com>2022-06-25 18:42:48 +0200
commit29a3cd05f60644ac1962f2cc5227f8bb4344a73a (patch)
treee5808dc020f0764cf2e39dd497072f911fc21793
parent52427732fc71c5398adb7d87dfca76d62de8ab6a (diff)
parent8c390dfd569ff6e5e484cb01db3d64107eb11213 (diff)
downloadecdsa-29a3cd05f60644ac1962f2cc5227f8bb4344a73a.tar.gz
Merge pull request #302 from tlsfuzzer/py3.11
Add Python 3.11 to test matrix, update python 3.10 docs
-rw-r--r--.github/workflows/ci.yml9
-rwxr-xr-xsetup.py2
2 files changed, 6 insertions, 5 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index ccafe09..112719c 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -87,11 +87,10 @@ jobs:
os: ubuntu-latest
python-version: '3.10'
tox-env: gmpy2py310
- # Python 3.11a3 segfaults when running the test suite so skip it for now
- #- name: py3.11
- # os: ubuntu-latest
- # python-version: '3.11.0-alpha.3'
- # tox-env: py311
+ - name: py3.11
+ os: ubuntu-latest
+ python-version: '3.11.0-beta.3'
+ tox-env: py311
- name: pypy
os: ubuntu-latest
python-version: pypy-2.7
diff --git a/setup.py b/setup.py
index b1a1ef9..f6a1dd1 100755
--- a/setup.py
+++ b/setup.py
@@ -41,6 +41,8 @@ setup(
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
],
install_requires=["six>=1.9.0"],
extras_require={"gmpy2": "gmpy2", "gmpy": "gmpy"},