summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCatherine Devlin <catherine.devlin@gmail.com>2013-02-19 05:46:34 -0500
committerCatherine Devlin <catherine.devlin@gmail.com>2013-02-19 05:46:34 -0500
commit7e054b303cca1ea38e0f725a10d237252c12418e (patch)
treef24102949d0f3c193a7ac4f95a604544d5a0011c
parent11abc9b946bf0c927437b7a5974d9dcf20b7dfdc (diff)
parent724076f50971e60eda0af034febd986cbe6e60c4 (diff)
downloadcmd2-hg-7e054b303cca1ea38e0f725a10d237252c12418e.tar.gz
account for pyparsing 2.0.0's support of Python 3 onlyy
-rwxr-xr-xsetup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4ef521d..4951959 100755
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,11 @@ except ImportError:
return ['sqlpython']
import sys
-install_requires = ['pyparsing>=1.5.6']
+if sys.version_info.major < 3:
+ install_requires = ['pyparsing == 1.5.7']
+else:
+ install_requires = ['pyparsing >= 2.0.0']
+
setup(
name="cmd2",
version="0.6.4",