summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCatherine Devlin <catherine.devlin@gmail.com>2013-02-19 04:33:12 -0500
committerCatherine Devlin <catherine.devlin@gmail.com>2013-02-19 04:33:12 -0500
commit724076f50971e60eda0af034febd986cbe6e60c4 (patch)
treebc5a5d2a4a0266848b9bd631cd620c4c95d97236
parentb476732bfa5d335f8c1cbfdaeeb4fcd34c629230 (diff)
downloadcmd2-hg-724076f50971e60eda0af034febd986cbe6e60c4.tar.gz
pyparsing 2.0.0 only if on Python3
-rwxr-xr-xsetup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4ef521d..4951959 100755
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,11 @@ except ImportError:
return ['sqlpython']
import sys
-install_requires = ['pyparsing>=1.5.6']
+if sys.version_info.major < 3:
+ install_requires = ['pyparsing == 1.5.7']
+else:
+ install_requires = ['pyparsing >= 2.0.0']
+
setup(
name="cmd2",
version="0.6.4",