summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcatherine devlin <catherine.devlin@gmail.com>2011-07-20 23:23:09 -0400
committercatherine devlin <catherine.devlin@gmail.com>2011-07-20 23:23:09 -0400
commit6beca32f8062826b76a1df6f89535fa7f455d9dd (patch)
treebb1d59f59385c6dfc66cf736706e3fd213eeb916
parent4976b28afe69fb036b294e986856d6c4072197df (diff)
downloadcmd2-hg-6beca32f8062826b76a1df6f89535fa7f455d9dd.tar.gz
require pyparsing 1.5.6 for its Python 3 power
-rwxr-xr-xcmd2.py7
-rwxr-xr-xsetup.py2
2 files changed, 2 insertions, 7 deletions
diff --git a/cmd2.py b/cmd2.py
index aebe618..46e29d4 100755
--- a/cmd2.py
+++ b/cmd2.py
@@ -40,12 +40,7 @@ import platform
import copy
from code import InteractiveConsole, InteractiveInterpreter
from optparse import make_option
-
-if sys.version_info[0] > 2:
- import pyparsing_py3 as pyparsing
- raw_input = input
-else:
- import pyparsing
+import pyparsing
__version__ = '0.6.3'
diff --git a/setup.py b/setup.py
index c220ac5..ae1dd43 100755
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,7 @@ except ImportError:
return ['sqlpython']
import sys
-install_requires = ['pyparsing>=1.5.5']
+install_requires = ['pyparsing>=1.5.6']
setup(
name="cmd2",
version="0.6.3",