summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcatherine devlin <catherine.devlin@gmail.com>2011-07-20 23:21:29 -0400
committercatherine devlin <catherine.devlin@gmail.com>2011-07-20 23:21:29 -0400
commit4976b28afe69fb036b294e986856d6c4072197df (patch)
tree4519edb1e307456980487cec0511091af90f260c
parent8d337bb7eef0204b052f2052cd8bdc2f1fdd613d (diff)
downloadcmd2-hg-4976b28afe69fb036b294e986856d6c4072197df.tar.gz
describe Distribute requirement
-rw-r--r--INSTALL.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/INSTALL.txt b/INSTALL.txt
index 2d99134..a6a21d5 100644
--- a/INSTALL.txt
+++ b/INSTALL.txt
@@ -4,17 +4,19 @@ Development trunk can be downloaded with mercurial::
hg clone http://hg.assembla.com/python-cmd2
-To install from the trunk, ``cd python-cmd2`` and run ``python setup.py install`` or ``python setup.py develop`` (requires setuptools).
+To install from the trunk, ``cd python-cmd2`` and run ``python setup.py install`` or ``python setup.py develop`` (requires setuptools). (Use ``root`` account, or ``sudo``, on *nix.)
Python 3
--------
The Python 3 egg downloaded from PyPI or installed by ``pip`` or ``easy_install`` is ready to go.
-To install from source for Python 3::
+To install from source for Python 3, the 2to3 transformations must be applied to ``cmd2.py``.
+The best way to do this is to install ``distribute`` on Python 3 before installing
+``cmd1``::
- 2to3 -w cmd2.py
- python3 setup.py install
-
+ curl -O http://python-distribute.org/distribute_setup.py
+ sudo python3 distribute_setup.py
- \ No newline at end of file
+ sudo python3 setup.py install
+