summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcatherine devlin <catherine.devlin@gmail.com>2011-07-20 21:23:53 -0400
committercatherine devlin <catherine.devlin@gmail.com>2011-07-20 21:23:53 -0400
commit8d337bb7eef0204b052f2052cd8bdc2f1fdd613d (patch)
treef30e0f28c2e1560639f87524e520a1204f78b693
parent6194bbe2f826137116b5d715a99c7531929b9a70 (diff)
downloadcmd2-hg-8d337bb7eef0204b052f2052cd8bdc2f1fdd613d.tar.gz
Python 3 installation instructions
-rw-r--r--INSTALL.txt20
-rwxr-xr-xcmd2.py2
2 files changed, 22 insertions, 0 deletions
diff --git a/INSTALL.txt b/INSTALL.txt
new file mode 100644
index 0000000..2d99134
--- /dev/null
+++ b/INSTALL.txt
@@ -0,0 +1,20 @@
+cmd2 can be installed from PyPI by ``easy_install`` or ``pip``.
+
+Development trunk can be downloaded with mercurial::
+
+ hg clone http://hg.assembla.com/python-cmd2
+
+To install from the trunk, ``cd python-cmd2`` and run ``python setup.py install`` or ``python setup.py develop`` (requires setuptools).
+
+Python 3
+--------
+
+The Python 3 egg downloaded from PyPI or installed by ``pip`` or ``easy_install`` is ready to go.
+
+To install from source for Python 3::
+
+ 2to3 -w cmd2.py
+ python3 setup.py install
+
+
+ \ No newline at end of file
diff --git a/cmd2.py b/cmd2.py
index bedae38..aebe618 100755
--- a/cmd2.py
+++ b/cmd2.py
@@ -221,6 +221,8 @@ else:
can_clip = True
except Exception: # hate a bare Exception call, but exception classes vary too much b/t stdlib versions
pass
+ except Exception:
+ pass # something went wrong with xclip and we cannot use it
if can_clip:
def get_paste_buffer():
xclipproc = subprocess.Popen('xclip -o -sel clip', shell=True, stdout=subprocess.PIPE, stdin=subprocess.PIPE)