summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@gmail.com>2013-09-09 09:43:29 -0400
committerDoug Hellmann <doug.hellmann@gmail.com>2013-09-09 09:43:29 -0400
commit174ae658413a4b789688dd07fa2017c1eac4d5e4 (patch)
treede6c9bba8e080f054529cc7c2790c4621973d6d4
parent292da230c82a4390193f486a3cece37824b200cf (diff)
downloadcmd2-hg-174ae658413a4b789688dd07fa2017c1eac4d5e4.tar.gz
Use the latest version of pyparsing when possible
The 2.0.1 release of pyparsing restores Python 2 and 3 compatibility, so use that instead of setting the version based on version of Python under which we are being installed. This facilitates dependencies that want to support both Python 2 and 3. Keep the dependency on 1.5.7 for Python 2.5, which is not supported by pyparsing 2.0.1.
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3670b92..2bf3815 100755
--- a/setup.py
+++ b/setup.py
@@ -7,10 +7,10 @@ except ImportError:
return ['sqlpython']
import sys
-if sys.version_info < (3, 0, 0):
+if sys.version_info[:2] == (2, 5):
install_requires = ['pyparsing == 1.5.7']
else:
- install_requires = ['pyparsing >= 2.0.0']
+ install_requires = ['pyparsing >= 2.0.1']
setup(
name="cmd2",