summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Rose <erik@mozilla.com>2018-01-03 11:52:31 -0500
committerErik Rose <erik@mozilla.com>2018-01-03 11:52:31 -0500
commit2b35169878f5ceab92b4e268579fa160069fb21d (patch)
treed8eb72cb09643cf1b8e61ab8b0e9dbf0a00dc3b9
parentffa68e2003281192943f4183e9d281515f93bfa4 (diff)
downloadblessings-2b35169878f5ceab92b4e268579fa160069fb21d.tar.gz
Bring Python versions under test up to date.modern-python-versions
To heck with 3.2. Keep 3.3 just in case there's something special about it; I don't remember. Add 3.6 because it's the newest. Move installation stuff to a Travis `install` block so it doesn't show up as a test failure if it breaks. Stop using pip's `--use-mirrors` option, which is gone in modern pips.
-rw-r--r--.travis.yml10
-rw-r--r--tox.ini2
2 files changed, 7 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index 41bab6b..b3ed372 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -3,15 +3,17 @@ language: python
python:
- 2.6
- 2.7
- - 3.2
+ - 3.3
+ - 3.6
- pypy
matrix:
allow_failures:
- - python: 3.2 # Not a new enough 3.2 for blessings
- python: pypy # PyPy doesn't have _curses.
-script:
- - pip install -q --use-mirrors nose
+install:
+ - pip install -q nose
- python setup.py install
+
+script:
- nosetests -w /tmp blessings.tests
diff --git a/tox.ini b/tox.ini
index 06bd4fd..a8c9b5a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py25, py26, py27, py32, py33
+envlist = py26, py27, py33, py36
[testenv]
commands = nosetests blessings