summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml10
1 files changed, 6 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 41bab6b..b3ed372 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -3,15 +3,17 @@ language: python
python:
- 2.6
- 2.7
- - 3.2
+ - 3.3
+ - 3.6
- pypy
matrix:
allow_failures:
- - python: 3.2 # Not a new enough 3.2 for blessings
- python: pypy # PyPy doesn't have _curses.
-script:
- - pip install -q --use-mirrors nose
+install:
+ - pip install -q nose
- python setup.py install
+
+script:
- nosetests -w /tmp blessings.tests