summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-09-09 18:05:13 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2018-09-17 09:55:25 -0700
commitf5ef8b9e679dc5a060f88b818783c55aa04bb3ca (patch)
tree21cb175562e9f0c39913948455896e8fbe5bcb3f /setup.py
parent7f4f3b626e7f2f6f2365c77a9b7f6dac72f41f12 (diff)
downloadappdirs-f5ef8b9e679dc5a060f88b818783c55aa04bb3ca.tar.gz
Drop support for EOL Pythons
Python 2.6, 3.2, and 3.3 are end of life. They are no longer receiving bug fixes, including for security issues. Python 2.6 went EOL on 2013-10-29, Python 3.2 on 2016-02-20, and Python 3.3 on 2017-09-29. For additional details on support Python versions, see: https://devguide.python.org/#status-of-python-branches https://devguide.python.org/devcycle/#end-of-life-branches Removing support for EOL Pythons will reduce testing and maintenance resources. Using pypinfo, here are the PyPI download statistics for the last 30 days, showing low numbers for EOL Pythons. | python_version | percent | download_count | | -------------- | ------: | -------------: | | 2.7 | 61.50% | 785,047 | | 3.6 | 24.17% | 308,576 | | 3.5 | 8.09% | 103,320 | | 3.7 | 3.23% | 41,242 | | 3.4 | 2.81% | 35,877 | | 2.6 | 0.13% | 1,622 | | 3.3 | 0.06% | 711 | | 3.8 | 0.01% | 174 | | None | 0.00% | 19 | | 3.2 | 0.00% | 7 |
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 0 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index dcd0ee1..3458387 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,5 @@
#!/usr/bin/env python
-import sys
import os
-import os.path
# appdirs is a dependency of setuptools, so allow installing without it.
try:
from setuptools import setup
@@ -9,10 +7,6 @@ except ImportError:
from distutils.core import setup
import ast
-tests_require = []
-if sys.version_info < (2, 7):
- tests_require.append("unittest2")
-
def read(fname):
inf = open(os.path.join(os.path.dirname(__file__), fname))
@@ -41,11 +35,8 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
@@ -54,8 +45,6 @@ setup(
'Programming Language :: Python :: Implementation :: CPython',
'Topic :: Software Development :: Libraries :: Python Modules',
],
- test_suite='test.test_api',
- tests_require=tests_require,
keywords='application directory log cache user',
author='Trent Mick',
author_email='trentm@gmail.com',