summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Rouse <jr@its.to>2018-09-11 23:24:35 -0700
committerGitHub <noreply@github.com>2018-09-11 23:24:35 -0700
commit3442ee661f62b39a88896a84fba9fb401101c5a4 (patch)
treec049c0d8db83a50cb9c51fcf78329852b4dc09da
parent422d7e471b1a1068caff15b264e51ad1e163d3f0 (diff)
parent8a917021e9cf8b3b8503260493b190ed1478d884 (diff)
downloadappdirs-3442ee661f62b39a88896a84fba9fb401101c5a4.tar.gz
Merge pull request #112 from jdufresne/https
Prefer https:// links where available
-rw-r--r--CHANGES.rst10
-rw-r--r--README.rst6
-rw-r--r--appdirs.py4
-rw-r--r--setup.py2
4 files changed, 11 insertions, 11 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index 55f5349..c2b680c 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -56,7 +56,7 @@ appdirs 1.1.0
- [issue 4] Add ``AppDirs.user_log_dir``.
- [Unix, issue 2, issue 7] appdirs now conforms to `XDG base directory spec
- <http://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html>`_.
+ <https://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html>`_.
- [Mac, issue 5] Fix ``site_data_dir()`` on Mac.
- [Mac] Drop use of 'Carbon' module in favour of hardcoded paths; supports
Python3 now.
@@ -83,10 +83,10 @@ appdirs 1.0.1 (never released)
------------------------------
Started this changelog 27 July 2010. Before that this module originated in the
-`Komodo <http://www.activestate.com/komodo>`_ product as ``applib.py`` and then
+`Komodo <https://www.activestate.com/komodo-ide>`_ product as ``applib.py`` and then
as `applib/location.py
-<http://github.com/ActiveState/applib/blob/master/applib/location.py>`_ (used by
-`PyPM <http://code.activestate.com/pypm/>`_ in `ActivePython
-<http://www.activestate.com/activepython>`_). This is basically a fork of
+<https://github.com/ActiveState/applib/blob/master/applib/location.py>`_ (used by
+`PyPM <https://code.activestate.com/pypm/>`_ in `ActivePython
+<https://www.activestate.com/activepython>`_). This is basically a fork of
applib.py 1.0.1 and applib/location.py 1.0.1.
diff --git a/README.rst b/README.rst
index dfafbdf..453eb02 100644
--- a/README.rst
+++ b/README.rst
@@ -1,5 +1,5 @@
.. image:: https://secure.travis-ci.org/ActiveState/appdirs.png
- :target: http://travis-ci.org/ActiveState/appdirs
+ :target: https://travis-ci.org/ActiveState/appdirs
the problem
===========
@@ -17,10 +17,10 @@ or possibly::
C:\Documents and Settings\<User>\Application Data\<AppAuthor>\<AppName>
-for `roaming profiles <http://bit.ly/9yl3b6>`_ but that is another story.
+for `roaming profiles <https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-vista/cc766489(v=ws.10)>`_ but that is another story.
On Linux (and other Unices) the dir, according to the `XDG
-spec <http://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html>`_, is::
+spec <https://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html>`_, is::
~/.local/share/<AppName>
diff --git a/appdirs.py b/appdirs.py
index f7f8359..975e9bf 100644
--- a/appdirs.py
+++ b/appdirs.py
@@ -5,13 +5,13 @@
"""Utilities for determining application-specific dirs.
-See <http://github.com/ActiveState/appdirs> for details and usage.
+See <https://github.com/ActiveState/appdirs> for details and usage.
"""
# Dev Notes:
# - MSDN on where to store app data files:
# http://support.microsoft.com/default.aspx?scid=kb;en-us;310294#XSLTH3194121123120121120120
# - Mac OS X: http://developer.apple.com/documentation/MacOSX/Conceptual/BPFileSystem/index.html
-# - XDG spec for Un*x: http://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html
+# - XDG spec for Un*x: https://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html
__version__ = "1.4.4"
__version_info__ = tuple(int(segment) for segment in __version__.split("."))
diff --git a/setup.py b/setup.py
index 9f0f331..9aa7756 100644
--- a/setup.py
+++ b/setup.py
@@ -59,7 +59,7 @@ setup(
author_email='trentm@gmail.com',
maintainer='Trent Mick; Sridhar Ratnakumar; Jeff Rouse',
maintainer_email='trentm@gmail.com; github@srid.name; jr@its.to',
- url='http://github.com/ActiveState/appdirs',
+ url='https://github.com/ActiveState/appdirs',
license='MIT',
py_modules=["appdirs"],
)