summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-08-28 03:30:37 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2018-09-16 11:10:55 -0700
commit1a18c554d148f7437b6bae5b02941d9f9044f489 (patch)
tree08c320853d0005a93a18834a06940df60bc35521
parent3442ee661f62b39a88896a84fba9fb401101c5a4 (diff)
downloadappdirs-1a18c554d148f7437b6bae5b02941d9f9044f489.tar.gz
Add testing and document support for Python 3.7
Python 3.7 was released on June 27, 2018. https://docs.python.org/3/whatsnew/3.7.html
-rw-r--r--.travis.yml7
-rw-r--r--CHANGES.rst4
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
4 files changed, 14 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index bf88651..cd874a5 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -8,4 +8,11 @@ python:
- "3.4"
- "3.5"
- "3.6"
+
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: true
+
script: python setup.py test
diff --git a/CHANGES.rst b/CHANGES.rst
index c2b680c..d4cabca 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,6 +1,10 @@
appdirs Changelog
=================
+UNRELEASED
+----------
+- Add Python 3.7 support
+
appdirs 1.4.4
-------------
- [PR #92] Don't import appdirs from setup.py which resolves issue #91
diff --git a/setup.py b/setup.py
index 9aa7756..dcd0ee1 100644
--- a/setup.py
+++ b/setup.py
@@ -39,6 +39,7 @@ setup(
'Intended Audience :: Developers',
'License :: OSI Approved :: MIT License',
'Operating System :: OS Independent',
+ 'Programming Language :: Python',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
@@ -48,6 +49,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: PyPy',
'Programming Language :: Python :: Implementation :: CPython',
'Topic :: Software Development :: Libraries :: Python Modules',
diff --git a/tox.ini b/tox.ini
index 85e3dd3..54482d7 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26, py27, py32, py33, py34, py35, py36
+envlist = py26, py27, py32, py33, py34, py35, py36, py37
[testenv]
commands = python setup.py test