summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-08-28 03:30:37 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2018-09-16 11:10:55 -0700
commit1a18c554d148f7437b6bae5b02941d9f9044f489 (patch)
tree08c320853d0005a93a18834a06940df60bc35521 /.travis.yml
parent3442ee661f62b39a88896a84fba9fb401101c5a4 (diff)
downloadappdirs-1a18c554d148f7437b6bae5b02941d9f9044f489.tar.gz
Add testing and document support for Python 3.7
Python 3.7 was released on June 27, 2018. https://docs.python.org/3/whatsnew/3.7.html
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml7
1 files changed, 7 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
index bf88651..cd874a5 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -8,4 +8,11 @@ python:
- "3.4"
- "3.5"
- "3.6"
+
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: true
+
script: python setup.py test