summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2011-02-15 17:31:16 +0100
committerDieter Verfaillie <dieterv@optionexplicit.be>2011-02-17 12:38:12 +0100
commitd82023765f874731214cfe9fcd53edb8734d234b (patch)
tree70a162c19499fb128c0f584c335cff6ddb5360bb /setup.py
parent0b535a9dbf5aa9c4095401d79f80e99c285a2313 (diff)
downloadpygtk-d82023765f874731214cfe9fcd53edb8734d234b.tar.gz
Add 'import pygtk; pygtk.require('2.0') statements where needed
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 3d352da3..6f225bb9 100755
--- a/setup.py
+++ b/setup.py
@@ -39,6 +39,9 @@ if sys.version_info[:3] < MIN_PYTHON_VERSION:
# Check for pygobject (dsextras)
try:
+ import pygtk
+ pygtk.require('2.0')
+
from dsextras import GLOBAL_MACROS, GLOBAL_INC, get_m4_define, getoutput, \
have_pkgconfig, pkgc_version_check, pkgc_get_defs_dir, \
PkgConfigExtension, Template, TemplateExtension, \