summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Warner <james.warner@comcast.net>2020-06-30 00:00:00 -0500
committerCraig Small <csmall@dropbear.xyz>2020-07-05 21:13:01 +1000
commit605ea4a8f7460920b6de9e432757bd13f80f0dba (patch)
tree451d617bca3dc86ff7e583ef5efd0a6e503ac010 /Makefile.am
parent1aa8b1644118ee84ff02158e1a9f409527fb5a96 (diff)
downloadprocps-ng-605ea4a8f7460920b6de9e432757bd13f80f0dba.tar.gz
library: make that 'escape_str' private to our library
In that commit referenced below, a promise was made to revisit an 'escape_str' function in efforts to make it private to the library. The problem was it's needed by both ps plus the library which is why it was exported. So, in an effort to remove it from libprocps.sym, this patch duplicates all the required code in ps/output.c. Now, each version can be made private to their caller. [ along the way we'll use this opportunity to remove ] [ the 'restrict' qualifiers from function parameters ] [ while swatting a compiler warning referenced below ] Reference(s): . April 2016, most escape functions made private commit d916d5db86cbbf552401026aab15c3663412d662 proc/escape.c: In function `escape_command': proc/escape.c:182:23: warning: initialization of `const char **' from incompatible pointer type `char **' [-Wincompatible-pointer-types] 182 | const char **lc = (char**)pp->cmdline; | ^ Signed-off-by: Jim Warner <james.warner@comcast.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c21658..e49dc10 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -276,7 +276,6 @@ proc_libprocps_la_includedir = $(includedir)/procps/
proc_libprocps_la_include_HEADERS = \
proc/devname.h \
proc/diskstats.h \
- proc/escape.h \
proc/meminfo.h \
proc/namespace.h \
proc/numa.h \