summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Warner <james.warner@comcast.net>2020-06-30 00:00:00 -0500
committerCraig Small <csmall@dropbear.xyz>2020-07-05 21:13:01 +1000
commit1aa8b1644118ee84ff02158e1a9f409527fb5a96 (patch)
treeb86e7fb1fdc221dc6901d95e702c1753bf48354a /Makefile.am
parent70fd03e461ee961597280280f60fef79c37562ad (diff)
downloadprocps-ng-1aa8b1644118ee84ff02158e1a9f409527fb5a96.tar.gz
library: eliminated the questionable 'procps.h' header
There was a time when that procps.h file served a more traditional role. Prior to the commit referenced below it held just macros plus manifest constants. But, with that change, such items were replaced with a series of includes embracing all the library exported functions. That approach was known to disguise errors which would have otherwise yielded a compiler warning. And without such a warning, there was no way to address the error. So this patch will trade the all inclusive header file approach for individual includes only where necessary. Reference(s): . April 2016, procps.h header file revamped commit ccb6ae8de14b0cde25b84369ef995bcd69cbf7b6 . Sept 2018, top abandoned use of procps.h commit a6dfc2382ed1e023dd345cdb1d2388c9b67bcc7f Signed-off-by: Jim Warner <james.warner@comcast.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 181edb5..3c21658 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -252,7 +252,6 @@ proc_libprocps_la_SOURCES = \
proc/numa.h \
proc/pids.c \
proc/pids.h \
- proc/procps.h \
proc/pwcache.c \
proc/pwcache.h \
proc/readproc.c \
@@ -282,7 +281,6 @@ proc_libprocps_la_include_HEADERS = \
proc/namespace.h \
proc/numa.h \
proc/pids.h \
- proc/procps.h \
proc/pwcache.h \
proc/readproc.h \
proc/slabinfo.h \