summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2013-03-29 12:08:12 -0700
committerDan Nicholson <dbn.lists@gmail.com>2013-04-09 05:45:40 -0700
commit4a0ab4be0b5381aea2e3ac9c3ba9bedbc5e0178f (patch)
tree60335a9902a592d4ac2b3987d93741b5ee68d368 /configure.ac
parent80c2777b22b6ae3407b0614df470fde0d0dd319c (diff)
downloadpkg-config-4a0ab4be0b5381aea2e3ac9c3ba9bedbc5e0178f.tar.gz
Check for Wine when cross-compiling to Windows
If Wine is available when cross-compiling to Windows, it can be used to run the test suite from the build machine.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 73f2cf4..94666a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,6 +154,13 @@ AC_MSG_RESULT([$native_win32])
AC_SUBST([native_win32])
AM_CONDITIONAL(NATIVE_WIN32, [test "x$native_win32" = xyes])
+dnl When cross compiling to Windows, Wine might be available to help
+dnl for testing.
+if test "$cross_compiling" = yes && test "$native_win32" = yes; then
+ AC_CHECK_PROG([WINE], [wine], [wine])
+ test "x$WINE" != x && TESTS_PKG_CONFIG='${WINE} '"$TESTS_PKG_CONFIG"
+fi
+
dnl
dnl Find glib or use internal copy. Required version is 2.16 for
dnl g_win32_get_package_installation_directory_of_module().