summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2013-03-29 11:52:27 -0700
committerDan Nicholson <dbn.lists@gmail.com>2013-04-09 05:45:40 -0700
commit80c2777b22b6ae3407b0614df470fde0d0dd319c (patch)
tree7a9ed60a2503e790649a0697f6a4552448a14ccb /configure.ac
parent85dce61788659b9cd3f51e936337e010ffb1f6bf (diff)
downloadpkg-config-80c2777b22b6ae3407b0614df470fde0d0dd319c.tar.gz
Substitute TESTS_PKG_CONFIG from configure
This just paves the way to calculate more useful defaults in a shell.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4de9b16..73f2cf4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,10 @@ AC_ARG_VAR([TESTS_SHELL], [Path to a POSIX shell to be used for testing])
conf_path="$PATH:`getconf PATH 2>/dev/null`"
AC_PATH_PROGS([TESTS_SHELL], [bash ksh sh], [$CONFIG_SHELL], [$conf_path])
+dnl The built pkg-config to use for testing. This allows it to be set
+dnl from the make command line if necessary.
+AC_SUBST([TESTS_PKG_CONFIG], ['${top_builddir}/pkg-config${EXEEXT}'])
+
dnl
dnl Default pkg-config search path
dnl