summaryrefslogtreecommitdiff
path: root/check/Makefile.am
diff options
context:
space:
mode:
authorTollef Fog Heen <tfheen@err.no>2008-03-23 21:39:07 +0100
committerTollef Fog Heen <tfheen@err.no>2008-03-23 21:39:07 +0100
commit69dafea1c8f4737b51e32ac1b9427076c70728c1 (patch)
tree29405f16b6d55211720cb234931240775a6d6f27 /check/Makefile.am
parent15e72cef72e0187ca5547e44888c391591359634 (diff)
downloadpkg-config-69dafea1c8f4737b51e32ac1b9427076c70728c1.tar.gz
2008-03-23 Tollef Fog Heen <tfheen@err.no>
* check/check-conflicts, check/conflicts-test.pc: New test, testing that conflicts work as they should. * pkg.c (verify_package): Make the conflicts check not only check package versions, but also package names. This makes conflicts functional, something they were not before.
Diffstat (limited to 'check/Makefile.am')
-rw-r--r--check/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/check/Makefile.am b/check/Makefile.am
index df199c7..772c8ad 100644
--- a/check/Makefile.am
+++ b/check/Makefile.am
@@ -1,6 +1,7 @@
TESTS = check-cflags check-libs check-define-variable \
- check-libs-private check-requires-private check-includedir
+ check-libs-private check-requires-private check-includedir \
+ check-conflicts
EXTRA_DIST = $(TESTS) common simple.pc requires-test.pc public-dep.pc \
private-dep.pc includedir.pc