summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2010-03-31 14:50:48 -0700
committerTollef Fog Heen <tfheen@err.no>2010-05-09 10:22:02 +0200
commita048ace79e0e1da2bc8c8697b0bf9b69a7ac62fc (patch)
tree7ce557f549dd9bf6fd7422253d2ccdc36290d3f7 /Makefile.am
parentaa4634eb31db5b428f0b6c8527e35c081992dfb5 (diff)
downloadpkg-config-a048ace79e0e1da2bc8c8697b0bf9b69a7ac62fc.tar.gz
Optionally use an external popt library
The one imported into pkg-config has seen very little maintenance, so let's give users the option to use the upstream version. The default is to use the included sources, but it can search for the system library using --with-installed-popt.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7681d2f..17a85c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,9 +6,16 @@ GLIB_SUBDIR = glib-1.2.10
included_glib_includes = -I./glib-1.2.10
pkg_config_LDADD=glib-1.2.10/libglib.la
endif
+
+if USE_INSTALLED_POPT
+pkg_config_LDADD += $(POPT_LIBS)
+else
pkg_config_LDADD += popt/libpopt.la
popt_includes = -I./popt
-SUBDIRS = $(GLIB_SUBDIR) popt check
+POPT_SUBDIR = popt
+endif
+
+SUBDIRS = $(GLIB_SUBDIR) $(POPT_SUBDIR) check
m4dir = $(datadir)/aclocal
m4_DATA = pkg.m4