summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2010-03-31 14:50:47 -0700
committerTollef Fog Heen <tfheen@err.no>2010-05-09 10:22:02 +0200
commitaa4634eb31db5b428f0b6c8527e35c081992dfb5 (patch)
tree40f5bbffb35a953cfca7ec0c620631db1b4cd884 /Makefile.am
parente58b5b94c6c7efa3854bb0a44fbde3d53e1b7684 (diff)
downloadpkg-config-aa4634eb31db5b428f0b6c8527e35c081992dfb5.tar.gz
Move popt to subdirectory and make a convenience library of it
This keeps a cleaner separation of the pkg-config sources and the imported popt sources.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 6 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index b9edccc..7681d2f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,9 @@ GLIB_SUBDIR = glib-1.2.10
included_glib_includes = -I./glib-1.2.10
pkg_config_LDADD=glib-1.2.10/libglib.la
endif
-SUBDIRS = $(GLIB_SUBDIR) check
+pkg_config_LDADD += popt/libpopt.la
+popt_includes = -I./popt
+SUBDIRS = $(GLIB_SUBDIR) popt check
m4dir = $(datadir)/aclocal
m4_DATA = pkg.m4
@@ -19,7 +21,8 @@ EXTRA_DIST = $(m4_DATA) $(man_MANS) README.win32
bin_PROGRAMS = pkg-config
AM_CFLAGS=@WARN_CFLAGS@
-INCLUDES=-DPKG_CONFIG_PC_PATH="\"$(pc_path)\"" $(included_glib_includes)
+INCLUDES=-DPKG_CONFIG_PC_PATH="\"$(pc_path)\"" $(included_glib_includes) \
+ $(popt_includes)
pkg_config_SOURCES= \
pkg.h \
@@ -28,11 +31,4 @@ pkg_config_SOURCES= \
parse.c \
main.c \
findme.c \
- findme.h \
- popt.c \
- popt.h \
- poptconfig.c \
- popthelp.c \
- poptint.h \
- poptparse.c
-
+ findme.h