summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorРуслан Ижбулатов <lrn1986@gmail.com>2011-04-14 07:25:43 +0400
committerTollef Fog Heen <tfheen@err.no>2011-04-14 08:19:50 +0200
commit7850aeb03a54a15d07b6c243b61033cd379c39d7 (patch)
tree13d9062d06807e049feb13ae43f7c07a3e6e36f0 /Makefile.am
parent01005bbbd0155b606c1f3df845ccfaff81e0c6ff (diff)
downloadpkg-config-7850aeb03a54a15d07b6c243b61033cd379c39d7.tar.gz
Escape slashes in paths passed to mingw-gcc
Avoids Msys path mangling that turns *nix paths (such as /usr/include) into DOS-style absolute paths (such as c:/mingw/msys/1.0/include). Allows mingw-built pkg-config to pass check-cflags.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b1f51ee..5b30ce8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,12 +21,21 @@ EXTRA_DIST = $(m4_DATA) $(man_MANS) README.win32
bin_PROGRAMS = pkg-config
AM_CFLAGS=@WARN_CFLAGS@
+if NATIVE_WIN32
+INCLUDES= \
+ -DPKG_CONFIG_PC_PATH="\"$(subst /,\/,$(pc_path))\"" \
+ -DPKG_CONFIG_SYSTEM_INCLUDE_PATH="\"$(subst /,\/,$(system_include_path))\"" \
+ -DPKG_CONFIG_SYSTEM_LIBRARY_PATH="\"$(subst /,\/,$(system_library_path))\"" \
+ @GLIB_CFLAGS@ \
+ $(popt_includes)
+else
INCLUDES= \
-DPKG_CONFIG_PC_PATH="\"$(pc_path)\"" \
-DPKG_CONFIG_SYSTEM_INCLUDE_PATH="\"$(system_include_path)\"" \
-DPKG_CONFIG_SYSTEM_LIBRARY_PATH="\"$(system_library_path)\"" \
@GLIB_CFLAGS@ \
$(popt_includes)
+endif
pkg_config_SOURCES= \
pkg.h \