summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2011-04-13 22:56:53 +0200
committerTollef Fog Heen <tfheen@err.no>2011-04-13 22:56:53 +0200
commit01005bbbd0155b606c1f3df845ccfaff81e0c6ff (patch)
treef0531f90f8e245a14da991d2d47d599c2316aeea /Makefile.am
parent57d6c40d7a202e2b953674781c2c145e44371781 (diff)
downloadpkg-config-01005bbbd0155b606c1f3df845ccfaff81e0c6ff.tar.gz
Add --with-system-include-path etc.
Instead of hard-coding /usr/include, we now use the environment variable PKG_CONFIG_SYSTEM_INCLUDE_PATH, defaulting to the argument of ./configure --with-system-include-path, which in turn defaults to /usr/include. Similarly, PKG_CONFIG_SYSTEM_LIBRARY_PATH defaults to /usr/lib or /usr/lib:/usr/lib64 as appropriate. (As currently implemented, this causes a behaviour change on Win32 - the option -I/usr/include will now be filtered out.) The intended usage is for Debian to configure pkg-config with --with-system-include-path=/usr/include/$(DEB_HOST_GNU_TYPE):/usr/include and the corresponding library path, for multiarch support (<http://bugs.debian.org/482884>). Based on work by Colin Walters <walters@verbum.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5fde154..b1f51ee 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,11 @@ EXTRA_DIST = $(m4_DATA) $(man_MANS) README.win32
bin_PROGRAMS = pkg-config
AM_CFLAGS=@WARN_CFLAGS@
-INCLUDES=-DPKG_CONFIG_PC_PATH="\"$(pc_path)\"" @GLIB_CFLAGS@ \
+INCLUDES= \
+ -DPKG_CONFIG_PC_PATH="\"$(pc_path)\"" \
+ -DPKG_CONFIG_SYSTEM_INCLUDE_PATH="\"$(system_include_path)\"" \
+ -DPKG_CONFIG_SYSTEM_LIBRARY_PATH="\"$(system_library_path)\"" \
+ @GLIB_CFLAGS@ \
$(popt_includes)
pkg_config_SOURCES= \