summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2015-10-16 12:49:18 +0800
committerDan Nicholson <dbn.lists@gmail.com>2015-10-26 09:15:53 -0700
commit56061ef3efdb74c04a852af1cce44df501438a2b (patch)
tree7b272030cba96f3ab3700d0e5a822cd20979f774 /Makefile.am
parentdd57ff354732b1caa181bf92f811e30304bb02a6 (diff)
downloadpkg-config-56061ef3efdb74c04a852af1cce44df501438a2b.tar.gz
build: Split Out Source Listing
Move the source listing into another Makefile module so that it can be shared with other Makefile-based build mechanisms.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index e46c798..be35ee2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,14 +29,8 @@ AM_CFLAGS = \
bin_PROGRAMS = pkg-config
pkg_config_LDADD = $(GLIB_LIBS)
-pkg_config_SOURCES= \
- pkg.h \
- pkg.c \
- parse.h \
- parse.c \
- rpmvercmp.c \
- rpmvercmp.h \
- main.c
+
+include Makefile.sources
if HOST_TOOL
host_tool = $(host)-pkg-config$(EXEEXT)