summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPradyun Gedam <pradyunsg@gmail.com>2021-10-15 18:31:10 +0100
committerGitHub <noreply@github.com>2021-10-15 18:31:10 +0100
commitbf71afc1435bf99ad9b027e0e9cc27b703e6d611 (patch)
tree91044220cd05523820eb6e7acc070b938ef77dc2 /pyproject.toml
parent82cc0225c9c3e066dc9d88251b02ff06588ce0a7 (diff)
parentaa89947b01a567be30fdabd59d87b55e8656a3a5 (diff)
downloadpip-bf71afc1435bf99ad9b027e0e9cc27b703e6d611.tar.gz
Merge pull request #10580 from pradyunsg/better-towncrier-template
Improve our towncrier template, to do the right thing after releases
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 9bb5900d0..53343bfce 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -3,13 +3,19 @@ requires = ["setuptools", "wheel"]
build-backend = "setuptools.build_meta"
[tool.towncrier]
+# For finding the __version__
package = "pip"
package_dir = "src"
+# For writing into the correct file
filename = "NEWS.rst"
+# For finding the news fragments
directory = "news/"
-title_format = "{version} ({project_date})"
+
+# For rendering properly for this project
issue_format = "`#{issue} <https://github.com/pypa/pip/issues/{issue}>`_"
template = "tools/news/template.rst"
+
+# Grouping of entries, within our changelog
type = [
{ name = "Process", directory = "process", showcontent = true },
{ name = "Deprecations and Removals", directory = "removal", showcontent = true },