summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPradyun Gedam <pradyunsg@users.noreply.github.com>2021-10-12 18:33:01 +0100
committerPradyun Gedam <pradyunsg@users.noreply.github.com>2021-10-15 15:11:43 +0100
commitaa89947b01a567be30fdabd59d87b55e8656a3a5 (patch)
tree0a3d0f8f9e398468c5921290b39369afb076906e /pyproject.toml
parent9d25d2aba53928cb77149b8854b6b8a8ccfd81b8 (diff)
downloadpip-aa89947b01a567be30fdabd59d87b55e8656a3a5.tar.gz
Improve our towncrier template, to do the right thing after releases
This also adds a bunch of comments, which should serve as useful guides to future humans that work on these files.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index fac279447..96a2a54f7 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -3,13 +3,19 @@ requires = ["setuptools", "wheel"]
build-backend = "setuptools.build_meta"
[tool.towncrier]
+# For finding the __version__
package = "pip"
package_dir = "src"
+# For writing into the correct file
filename = "NEWS.rst"
+# For finding the news fragments
directory = "news/"
-title_format = "{version} ({project_date})"
+
+# For rendering properly for this project
issue_format = "`#{issue} <https://github.com/pypa/pip/issues/{issue}>`_"
template = "tools/news/template.rst"
+
+# Grouping of entries, within our changelog
type = [
{ name = "Process", directory = "process", showcontent = true },
{ name = "Deprecations and Removals", directory = "removal", showcontent = true },