summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot <linkmauve@linkmauve.fr>2020-07-31 16:39:10 +0200
committerTony Wasserka <tony.wasserka@gmx.de>2021-10-01 10:40:18 +0200
commitc238faf74605842d7e8d40064da28bb9dd83d933 (patch)
tree71b38c02b474c60e20abccaf54573f2ba6331935 /src/meson.build
parentb70e551a5131c6231e75f5ad24cb480694b07b67 (diff)
downloadmesa-c238faf74605842d7e8d40064da28bb9dd83d933.tar.gz
radv: Allow building when LLVM isn’t enabled
Now that ACO is considered feature-complete, it can be nice to avoid the huge LLVM dependency when one only wants a Vulkan driver. This patch allows radv to be built without LLVM. The two features which get disabled are RADV_DEBUG=llvm and shader disassembly. The latter is an issue for debugging, so I added a warning that this configuration is unsupported. Reviewed-by: Samuel Pitoiset <samuel.pitoiset@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/11319>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index d99522cfd2c..5a4d329db0c 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -24,11 +24,16 @@ inc_src = include_directories('.')
inc_gallium = include_directories('gallium/include')
inc_gallium_aux = include_directories('gallium/auxiliary')
inc_amd_common = include_directories('amd/common')
-inc_amd_common_llvm = include_directories('amd/llvm')
inc_tool = include_directories('tool')
pps_datasources = []
pps_includes = []
+if with_llvm
+ inc_amd_common_llvm = include_directories('amd/llvm')
+else
+ inc_amd_common_llvm = []
+endif
+
libglsl_util = static_library(
'glsl_util',
files(