summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorBenjamin Gordon <bmgordon@chromium.org>2018-06-13 16:17:32 -0600
committerGurchetan Singh <gurchetansingh@chromium.org>2019-03-21 10:18:31 -0700
commitb30aad552cde507a70c6bf3bc2ce40ed69e0ecf2 (patch)
treea3b516755365b867863253b75accecc4fdae8899 /meson_options.txt
parente426c3a6cb020d1b156415e20c6f53a7195f96cd (diff)
downloadmesa-b30aad552cde507a70c6bf3bc2ce40ed69e0ecf2.tar.gz
configure.ac/meson.build: Add options for library suffixes
When building the Chrome OS Android container, we need to build copies of mesa that don't conflict with the Android system-supplied libraries. This adds options to create suffixed versions of EGL and GLES libraries: libEGL.so -> libEGL${egl-lib-suffix}.so libGLESv1_CM.so -> libGLESv1_CM${gles-lib-suffix}.so libGLESv2.so -> libGLES${gles-lib-suffix}.so This is similar to what happens when --enable-libglvnd is specified, but without the side effects of linking against libglvnd. To avoid unexpected clashes with the suffixed appended by libglvnd, make it an error to specify both --enable-libglvnd and --with-egl-lib-suffix. Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson_options.txt b/meson_options.txt
index 6c14fd503b9..45faa341e79 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -336,3 +336,14 @@ option(
value : false,
description : 'Allow work-in-progress freedreno vulkan driver to be enabled',
)
+option('egl-lib-suffix',
+ type : 'string',
+ value : '',
+ description : 'Suffix to append to EGL library name. Default: none.'
+)
+option(
+ 'gles-lib-suffix',
+ type : 'string',
+ value : '',
+ description : 'Suffix to append to GLES library names. Default: none.'
+)