summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorpal1000 <liviuprodea@yahoo.com>2022-10-10 00:56:03 +0300
committerMarge Bot <emma+marge@anholt.net>2022-12-16 16:52:48 +0000
commitf69b43ae3ef9a34ea360d96dfc698f83fad7a823 (patch)
tree2693af579aa7a53c2555e149d0696df500fbbb48 /meson.build
parent83617f4a57b94c5d33c7b825b67caeeebeb199b8 (diff)
downloadmesa-f69b43ae3ef9a34ea360d96dfc698f83fad7a823.tar.gz
OpenCL/draw module: Support linking with LLVM and clang 15 static libraries
Cc: mesa-stable Closes: #7243 Closes: #7487 Reviewed-by: Karol Herbst <kherbst@redhat.com> Reviewed-by: Yonggang Luo <luoyonggang@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19009>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 11 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 8cc6c0f5731..5c5b70a2d8a 100644
--- a/meson.build
+++ b/meson.build
@@ -1785,15 +1785,21 @@ if with_gallium_opencl
'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
'lto', 'option', 'objcarcopts', 'profiledata'
]
- llvm_optional_modules += ['all-targets', 'frontendopenmp']
+ # all-targets is needed to support static linking LLVM build with multiple targets
+ # windowsdriver is needded with LLVM>=15, but we don't know what LLVM verrsion we are using yet
+ llvm_optional_modules += ['all-targets', 'frontendopenmp', 'windowsdriver']
endif
if with_clc
llvm_modules += ['coverage', 'target', 'linker', 'irreader', 'option', 'libdriver', 'lto']
- llvm_optional_modules += ['all-targets']
+ # all-targets is needed to support static linking LLVM build with multiple targets
+ # windowsdriver is needded with LLVM>=15, but we don't know what LLVM verrsion we are using yet
+ llvm_optional_modules += ['all-targets', 'windowsdriver']
endif
draw_with_llvm = get_option('draw-use-llvm')
if draw_with_llvm
llvm_modules += 'native'
+ # lto is needded with LLVM>=15, but we don't know what LLVM verrsion we are using yet
+ llvm_optional_modules += ['lto']
endif
if with_intel_clc
@@ -1951,6 +1957,9 @@ if with_clc
'clangHandleCXX', 'clangHandleLLVM', 'clangSerialization',
'clangSema', 'clangParse', 'clangEdit', 'clangAnalysis'
]
+ if dep_llvm.version().version_compare('>= 15.0')
+ clang_modules += 'clangSupport'
+ endif
dep_clang = []
foreach m : clang_modules