summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-04-18 13:17:50 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-09-10 20:36:47 +0000
commite1e2388f06df1c9ab145c99d8f0f6cea22815528 (patch)
tree5219ca19c46973d4776103083c43d1fd90328d8d /meson.build
parent70cac06bbf4944b5d1aebe33a0dd6cbe8a2fdbb7 (diff)
downloadmesa-e1e2388f06df1c9ab145c99d8f0f6cea22815528.tar.gz
meson: don't build glx or dri by default on windows
v5: - Move is windows check down to make code more robust Reviewed-by: Eric Anholt <eric@anholt.net> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1ab21dfc2f5..26c1b0bb376 100644
--- a/meson.build
+++ b/meson.build
@@ -320,6 +320,8 @@ if with_glx == 'auto'
with_glx = 'dri'
elif with_platform_haiku
with_glx = 'disabled'
+ elif host_machine.system() == 'windows'
+ with_glx = 'disabled'
elif with_gallium
# Even when building just gallium drivers the user probably wants dri
with_glx = 'dri'